
Created in COMSOL Multiphysics 6.0
C e r am i c  Wa t e r  F i l t e r  w i t h  A c t i v a t e d  C a r bon Co r e
This model is licensed under the COMSOL Software License Agreement 6.0.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

This example illustrates how to model the transport of different contaminants through a 
ceramic water filter candle with an activated carbon core. This type of water filter can be 
found in tabletop gravity filters as well as attached to the faucet or as part of a larger reverse 
osmosis filter system. It shows how to set up the flow and transport equations to model 
different filter mechanisms and examines the effect of a small fracture in the ceramics part.

Our drinking water contains various impurities. These can be simply particles of dirt, 
which lead to turbidity of the water or cause unpleasant odors, such as chlorine. There can 
also be dangerous bacteria like Escherichia coli. That is why in many regions, water is 
disinfected by chlorination, thus destroying dangerous pathogens. The drawback of 
chlorination is on the one hand the resulting odor, on the other hand a reaction of chlorine 
with organic substances present in water can form harmful by-products such as the 
carcinogenic trihalomethanes.

Representative for these different pollutants, the model refers to chlorine and the 
trihalomethane chloroform. The term “particles” covers all substances that are filtered out 
of the water based solely on their size.

Model Definition

The model geometry is shown in Figure 1. The geometric properties are listed in Table 1. 

Figure 1: Sketch of the modeled filter.
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Tap water containing different impurities enters the filter with an inlet pressure of 
pin=6 psi. First, the water passes through the fine pored ceramic, in which particles with a 
larger diameter than the pore size are filtered out. The fracture in the ceramic has a 
relatively large aperture such that particles can travel almost unhindered and enter the 
activated carbon part.

Activated carbon has a large surface area and is mostly used in granular form in domestic 
water filters. The advantage of granular-activated carbon compared to powdered-activated 
carbon is the smaller pressure drop due to its relatively large particle size. At the same time 
this results in a smaller surface area available for reaction and adsorption. The effect on the 
adsorption capacity of trihalomethanes like chloroform is similar. The activated carbon is 
thus used up over time, which makes regular replacement of the filter necessary. In large 
filter systems the activated carbon can be backwashed.

F L U I D  F L O W

The flow velocity u (SI unit: m/s) through the filter depends on the gradient of the 
pressure p (SI unit: Pa) as described by Darcy’s law. 

Here, κ (SI unit: m2) and μ (SI unit: Pa·s) are the permeability of the filter and dynamic 
viscosity of water, respectively. For the ceramic part a fixed value for the permeability is 
assumed and the permeability for the activated carbon is calculated according to the 
Kozeny–Carman equation.

The flow in the fracture is in general much faster than in the surrounding porous matrix. 
The cubic law is a common correlation for modeling fracture flow. It defines the 
permeability κf (SI unit: m2) in the fracture according to

TABLE 1:  GEOMETRY PARAMETERS

Name Value Description

r_filter 2.2 cm Filter radius

l_filter 14.5 cm Filter length

th_ceramics 0.8 cm Thickness ceramics

th_carbon 1 cm Thickness carbon

th_attachement 4 mm Thickness mount
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The values used to set up Darcy’s law for the different sections are listed in Table 2.

C O N T A M I N A N T  T R A N S P O R T

Precise values of reaction of chlorine and adsorption rates of chloroform must be measured 
for each type of activated carbon. Adsorption is modeled using a Freundlich adsorption 
isotherm. The values used in this model are listed in the Table 3.

The simulation covers a period of two minutes. Afterward, a quasi-stationary state is 
reached and the filter efficiency can be determined.

TABLE 2:  DARCY’S LAW PARAMETER

Name Value Description

por_ceramics 0.18 Porosity, ceramics

por_carbon 0.45 Porosity, activated carbon

por_fracture 0.7 Porosity fracture

df 0.2 mm Fracture aperture

dp_carbon 20 μm Granular carbon diameter

kappa_ceramics 8·10-12 m2 Permeability ceramics

p_in 6 psi Inlet pressure

TABLE 3:  TRANSPORT PROPERTIES

Name Value Description

R_cl 0.391/s Reaction rate chlorine

S_cp -0.16 1/s Particle sink term

Kf 10 Freundlich constant, chloroform

Nf 2 Freundlich exponent, chloroform

cref_chcl3 0.5 mol/m3 Reference concentration, chloroform

κf
df

2

12ff
----------=
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Results and Discussion

The pressure and velocity field is shown in Figure 2.

Figure 2: Pressure distribution (color) and flow field (arrows).
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The particle concentration after 2 minutes is shown in Figure 3. One can see that the 
particles are filtered out immediately at the surface. It is mainly the fracture that allows the 
particles to pass the filter.

Figure 3: Particle concentration in the filter.
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Figure 4 shows the chlorine concentration after 2 minutes. After chlorine has passed the 
ceramic part, it is removed from the water by the reaction with activated carbon.

Figure 4: Chlorine concentration after 2 minutes.
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The concentration of dangerous chloroform is shown in Figure 5. It clearly shows that this 
filter is not suitable for the removal of chloroform. Usually, trihalomethanes are already 
filtered in the waterworks, with a very strict upper limit — often 0.

Figure 5: Chloroform concentration after 2 minutes.
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To evaluate the performance of this filter, we evaluate the ratio between the concentration 
at the outlet and the concentration at the inlet as shown in Figure 6.

Figure 6: Effectiveness of the filter. Ratio of the concentration at the outlet to the initial 
concentration.

Notes About the COMSOL Implementation

In this model it is assumed that the flow field does not depend on the species 
concentrations. This is a reasonable assumption for the time interval considered. If the 
filter is examined over a long period of time, the particles clog the pores of the ceramic, 
which leads to a higher pressure drop. In addition, the activated carbon is used up, which 
means that less chlorine and chloroform is removed.

The fracture in the ceramic filter is implemented as a surface within the 3D domain. This 
is possible due to the special boundary conditions that are available for the Darcy’s Law 
and the Transport of Diluted Species interface. They make it possible to simplify the model 
geometry to save computational resources.

Reference

1. https://www.freshwatersystems.com/blogs/blog
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Application Library path: Porous_Media_Flow_Module/Solute_Transport/
ceramic_water_filter

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Fluid Flow>Porous Media and Subsurface Flow>

Darcy’s Law (dl).

3 Click Add.

4 In the Select Physics tree, select Chemical Species Transport>

Transport of Diluted Species in Porous Media (tds).

5 Click Add.

The transport of three different substances is studied: particles which are filtered in the 
ceramic due to their size, chlorine which reacts with the activated carbon, and 
chloroform which is adsorbed by the activated carbon.

6 In the Number of species text field, type 3.

7 In the Concentrations table, enter the following settings:

8 Click Study.

9 In the Select Study tree, select General Studies>Stationary.

10 Click Done.

G E O M E T R Y  1

Start importing the geometry sequence from a file. This file also includes geometry 
parameters and selections.

c_p

c_cl

c_chcl3
10 |  C E R A M I C  W A T E R  F I L T E R  W I T H  A C T I V A T E D  C A R B O N  C O R E



1 In the Model Builder window, expand the Component 1 (comp1)>Geometry 1 node.

2 Right-click Geometry 1 and choose Insert Sequence.

3 Browse to the model’s Application Libraries folder and double-click the file 
ceramic_water_filter_geom_sequence.mph.

4 In the Geometry toolbar, click Build All.

G L O B A L  D E F I N I T I O N S

Parameters: Geometry
1 In the Model Builder window, under Global Definitions click Parameters 1.

2 In the Settings window for Parameters, type Parameters: Geometry in the Label text 
field.

Parameters: Transport
Now enter the parameters needed for the species transport equations and for Darcy’s law. 
You can import the corresponding files as follows:

1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Parameters: Transport in the Label text 
field.

3 Locate the Parameters section. Click Load from File.
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4 Browse to the model’s Application Libraries folder and double-click the file 
ceramic_water_filter_transport_parameters.txt.

Parameters: Darcy
1 In the Home toolbar, click Parameters and choose Add>Parameters.

2 In the Settings window for Parameters, type Parameters: Darcy in the Label text field.

3 Locate the Parameters section. Click Load from File.

4 Browse to the model’s Application Libraries folder and double-click the file 
ceramic_water_filter_Darcy_parameters.txt.

M A T E R I A L S

Continue with adding the materials. Water is used from the built-in material library. All 
other materials are user defined. Which material properties are required will be determined 
during the physics setup.

A D D  M A T E R I A L

1 In the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-in>Water, liquid.

4 Click Add to Component in the window toolbar.

5 In the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Porous Material: Ceramics
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose More Materials>Porous Material.

2 In the Settings window for Porous Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Ceramics.

4 In the Label text field, type Porous Material: Ceramics.

Porous Material: Carbon
1 Right-click Materials and choose More Materials>Porous Material.

2 In the Settings window for Porous Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Carbon.

4 In the Label text field, type Porous Material: Carbon.
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Fracture
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Fracture in the Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, 
choose Boundary.

4 From the Selection list, choose Fracture.

D A R C Y ’ S  L A W  ( D L )

The geometry also contains the mount, which is not relevant for the simulation. Each 
interface should be active on the modeling domains only.

1 In the Model Builder window, under Component 1 (comp1) click Darcy’s Law (dl).

2 In the Settings window for Darcy’s Law, locate the Domain Selection section.

3 From the Selection list, choose Modeling domains.

Porous Medium 2
1 In the Physics toolbar, click Domains and choose Porous Medium.

2 In the Settings window for Porous Medium, locate the Domain Selection section.

3 From the Selection list, choose Carbon.

Porous Matrix 1
1 In the Model Builder window, click Porous Matrix 1.

2 In the Settings window for Porous Matrix, locate the Matrix Properties section.

3 From the Permeability model list, choose Kozeny-Carman.

4 In the dp text field, type dp_carbon.

Fracture Flow 1
1 In the Physics toolbar, click Boundaries and choose Fracture Flow.

2 In the Settings window for Fracture Flow, locate the Boundary Selection section.

3 From the Selection list, choose Fracture.

Fluid and Fracture Properties 1
1 In the Model Builder window, expand the Fracture Flow 1 node, then click 

Fluid and Fracture Properties 1.

2 In the Settings window for Fluid and Fracture Properties, locate the Fluid Properties 
section.

3 From the Fluid material list, choose Water, liquid (mat1).
13 |  C E R A M I C  W A T E R  F I L T E R  W I T H  A C T I V A T E D  C A R B O N  C O R E



4 Locate the Fracture Properties section. From the Permeability model list, choose 
Cubic law.

Aperture 1
1 In the Model Builder window, click Aperture 1.

2 In the Settings window for Aperture, locate the Aperture section.

3 In the df text field, type df.

Pressure 1
A pressure of 6psi is assumed as inlet condition. This is a typical value for the pressure 
acting on a filter connected to the water supply.

1 In the Physics toolbar, click Boundaries and choose Pressure.

2 In the Settings window for Pressure, locate the Boundary Selection section.

3 From the Selection list, choose Unfiltered water inlet.

4 Locate the Pressure section. In the p0 text field, type p_in.

Pressure 2
1 In the Physics toolbar, click Boundaries and choose Pressure.

2 In the Settings window for Pressure, locate the Boundary Selection section.

3 From the Selection list, choose Filtered water outlet.

T R A N S P O R T  O F  D I L U T E D  S P E C I E S  I N  P O R O U S  M E D I A  ( T D S )

1 In the Model Builder window, under Component 1 (comp1) click 
Transport of Diluted Species in Porous Media (tds).

Make sure that this interface is deactivated on the mount.

2 In the Settings window for Transport of Diluted Species in Porous Media, locate the 
Domain Selection section.

3 From the Selection list, choose Modeling domains.

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>

Transport of Diluted Species in Porous Media (tds)>Porous Medium 1 click Fluid 1.

2 In the Settings window for Fluid, locate the Convection section.

3 From the u list, choose Darcy’s velocity field (dl).

Duplicate this node and define the adsorption properties of chloroform on activated 
carbon.
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Porous Medium 2
1 In the Model Builder window, under Component 1 (comp1)>

Transport of Diluted Species in Porous Media (tds) right-click Porous Medium 1 and 
choose Duplicate.

2 In the Settings window for Porous Medium, locate the Domain Selection section.

3 From the Selection list, choose Carbon.

Adsorption 1
1 In the Physics toolbar, click Attributes and choose Adsorption.

2 In the Settings window for Adsorption, locate the Adsorption section.

3 From the Adsorption isotherm list, choose Freundlich.

4 Select the Species c_chcl3 check box.

5 In the KF,cchcl3 text field, type Kf.

6 In the NF,cchcl3 text field, type Nf.

7 In the cref,cchcl3 text field, type cref_chcl3.

Species Source 1
The filtration of the particles can be described as a sink term. In contrast, chlorine and 
chloroform are not removed.

1 In the Physics toolbar, click Domains and choose Species Source.

2 In the Settings window for Species Source, locate the Domain Selection section.

3 From the Selection list, choose Ceramics.

4 Locate the Species Source section. In the Scp text field, type S_cp*c_p.

Reactions 1
Chlorine is removed from the water by a reaction with carbon.

1 In the Physics toolbar, click Domains and choose Reactions.

2 In the Settings window for Reactions, locate the Domain Selection section.

3 From the Selection list, choose Carbon.

4 Locate the Reaction Rates section. In the Rccl text field, type -R_cl*c_cl.

Fracture 1
1 In the Physics toolbar, click Boundaries and choose Fracture.

2 In the Settings window for Fracture, locate the Boundary Selection section.

3 From the Selection list, choose Fracture.
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4 Locate the Fracture Properties section. In the dfr text field, type df.

5 Locate the Convection section. From the u list, choose Darcy’s velocity field (dl).

6 Locate the Diffusion section. From the Fluid material list, choose Water, liquid (mat1).

Concentration 1
To complete setting up the physics, add the boundary conditions for the transport 
equations.

1 In the Physics toolbar, click Boundaries and choose Concentration.

2 In the Settings window for Concentration, locate the Boundary Selection section.

3 From the Selection list, choose Unfiltered water inlet.

4 Locate the Concentration section. Select the Species c_p check box.

5 In the c0,cp text field, type c_p0.

6 Select the Species c_cl check box.

7 In the c0,ccl text field, type c_cl0.

8 Select the Species c_chcl3 check box.

9 In the c0,cchcl3 text field, type c_chcl30.

Outflow 1
1 In the Physics toolbar, click Boundaries and choose Outflow.

2 In the Settings window for Outflow, locate the Boundary Selection section.

3 From the Selection list, choose Filtered water outlet.

M A T E R I A L S

Now the missing material properties can be added.

Porous Material: Ceramics (pmat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click 

Porous Material: Ceramics (pmat1).

2 In the Settings window for Porous Material, locate the Porosity section.

3 In the εp text field, type por_ceramics.
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4 Locate the Homogenized Properties section. In the table, enter the following settings:

5 Locate the Phase-Specific Properties section. Click Add Required Phase Nodes.

Fluid 1 (pmat1.fluid1)
1 In the Model Builder window, click Fluid 1 (pmat1.fluid1).

2 In the Settings window for Fluid, locate the Fluid Properties section.

3 From the Material list, choose Water, liquid (mat1).

Porous Material: Carbon (pmat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click 

Porous Material: Carbon (pmat2).

2 In the Settings window for Porous Material, locate the Porosity section.

3 In the εp text field, type por_carbon.

4 Locate the Phase-Specific Properties section. Click Add Required Phase Nodes.

Fluid 1 (pmat2.fluid1)
1 In the Model Builder window, click Fluid 1 (pmat2.fluid1).

2 In the Settings window for Fluid, locate the Fluid Properties section.

3 From the Material list, choose Water, liquid (mat1).

Solid 1 (pmat2.solid1)
1 In the Model Builder window, click Solid 1 (pmat2.solid1).

2 In the Settings window for Solid, locate the Solid Properties section.

3 In the θs text field, type 1-por_carbon.

4 Locate the Material Contents section. In the table, enter the following settings:

Fracture (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click 

Fracture (mat2).

Property Variable Value Unit Property 
group

Permeability kappa_iso ; 
kappaii = 
kappa_iso, 
kappaij = 0

kappa_cer
amics

m² Basic

Property Variable Value Unit Property group

Density rho 375 kg/m³ Basic
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2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

M E S H  1

Set up a proper mesh. High gradients for the particle concentration are expected at the 
filter boundaries due to the relatively large sink term. These gradients can be efficiently 
resolved with a boundary layer mesh. Also limit the maximum element size to resolve the 
geometry properly.

Free Triangular 1
1 In the Mesh toolbar, click Boundary and choose Free Triangular.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Fracture.

Size 1
1 Right-click Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. Select the Maximum element size check box.

5 In the associated text field, type 0.001.

Free Tetrahedral 1
1 In the Mesh toolbar, click Free Tetrahedral.

2 In the Settings window for Free Tetrahedral, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Modeling domains.

Size 1
1 Right-click Free Tetrahedral 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Extra fine.

4 Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type th_ceramics/3.

Property Variable Value Unit Property group

Porosity epsilon por_fracture 1 Basic
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Boundary Layers 1
1 In the Mesh toolbar, click Boundary Layers.

2 In the Settings window for Boundary Layers, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Ceramics.

Boundary Layer Properties
1 In the Model Builder window, click Boundary Layer Properties.

2 In the Settings window for Boundary Layer Properties, locate the Boundary Selection 
section.

3 From the Selection list, choose Unfiltered water inlet.

4 Locate the Layers section. In the Number of layers text field, type 5.

Free Tetrahedral 2
In the Mesh toolbar, click Free Tetrahedral.

Size
1 In the Model Builder window, click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Extra fine.

4 Click Build All.

S T U D Y  1

The simulation should take 2 minutes. Within this time interval the flow can be regarded 
as independent of the concentration.

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 In the table, enter the following settings:

4 In the Model Builder window, click Study 1.

5 In the Settings window for Study, locate the Study Settings section.

Physics interface Solve for Equation form

Transport of Diluted Species in 
Porous Media (tds)

Automatic (Stationary)
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6 Clear the Generate default plots check box.

Solve the stationary Darcian flow field, followed by a transient study step for the species 
transport.

Time Dependent
1 In the Study toolbar, click Study Steps and choose Time Dependent>

Time Dependent.

2 In the Settings window for Time Dependent, locate the Physics and Variables Selection 
section.

3 In the table, clear the Solve for check box for Darcy’s Law (dl).

4 Locate the Study Settings section. In the Output times text field, type range(0,0.1,6) 
range(8,2,120).

Solution 1 (sol1)
1 In the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click Time-

Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time Stepping 
section.

4 From the Steps taken by solver list, choose Strict.

A tight time step, particularly at the beginning of the simulation, is necessary to resolve 
the transition from the initial values (zero concentrations) to the applied boundary 
conditions.

5 In the Study toolbar, click Compute.

R E S U L T S

Create a new datset which is used to visualize the geometry.

Surface 1
1 In the Model Builder window, expand the Results node.

2 Right-click Results>Datasets and choose Surface.

3 In the Settings window for Surface, locate the Selection section.

4 From the Selection list, choose All boundaries.

5 Click the Wireframe Rendering button in the Graphics toolbar.

6 Press and hold the Ctrl key and mark the following boundaries in the Selection list: 11, 
13, 15-18, 22, 24, and 36. Then click the Remove from selection button next to it.
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7 In the list, choose 11, 13, 15, 16, 17, 18, 22, 24, and 36.

8 Click Remove from Selection.

9 Select Boundaries 1–10, 12, 14, 19–21, 23, 25–35, and 37–71 only.

To create Figure 2, follow the steps below.

Pressure
1 In the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Pressure in the Label text field.

3 Locate the Plot Settings section. Clear the Plot dataset edges check box.

Multislice 1
1 In the Pressure toolbar, click More Plots and choose Multislice.

2 In the Settings window for Multislice, locate the Multiplane Data section.

3 Find the Z-planes subsection. In the Planes text field, type 0.

Surface 1
1 In the Model Builder window, right-click Pressure and choose Surface.

2 In the Settings window for Surface, click to expand the Inherit Style section.

3 From the Plot list, choose Multislice 1.

Selection 1
1 Right-click Surface 1 and choose Selection.
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2 In the Settings window for Selection, locate the Selection section.

3 From the Selection list, choose Fracture.

Surface 2
1 In the Model Builder window, right-click Pressure and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Surface 1.

4 Locate the Expression section. In the Expression text field, type 1.

5 Click to expand the Title section. From the Title type list, choose None.

6 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

7 From the Color list, choose Gray.

Arrow Volume 1
1 Right-click Pressure and choose Arrow Volume.

2 In the Settings window for Arrow Volume, locate the Coloring and Style section.

3 From the Color list, choose Black.

4 In the Pressure toolbar, click Plot.

Particle concentration
1 In the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Particle concentration in the Label 
text field.

Multislice 1
1 In the Particle concentration toolbar, click More Plots and choose Multislice.

2 In the Settings window for Multislice, locate the Expression section.

3 In the Expression text field, type c_p.

4 Locate the Multiplane Data section. Find the Z-planes subsection. In the Planes text field, 
type 0.

5 Locate the Coloring and Style section. From the Color table list, choose AuroraAustralis.

6 Click to expand the Quality section. From the Recover list, choose Everywhere.

7 In the Particle concentration toolbar, click Plot.

Create the plot for the particle concentration as in Figure 3.

Surface 1
1 In the Model Builder window, right-click Particle concentration and choose Surface.
22 |  C E R A M I C  W A T E R  F I L T E R  W I T H  A C T I V A T E D  C A R B O N  C O R E



2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type c_p.

4 Locate the Inherit Style section. From the Plot list, choose Multislice 1.

Selection 1
1 Right-click Surface 1 and choose Selection.

2 In the Settings window for Selection, locate the Selection section.

3 From the Selection list, choose Fracture.

Surface 2
1 In the Model Builder window, right-click Particle concentration and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Dataset list, choose Surface 1.

4 Locate the Expression section. In the Expression text field, type 1.

5 Locate the Title section. From the Title type list, choose None.

6 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

7 From the Color list, choose Gray.

Particle concentration
1 In the Model Builder window, click Particle concentration.

2 In the Settings window for 3D Plot Group, locate the Plot Settings section.

3 Clear the Plot dataset edges check box.

4 In the Particle concentration toolbar, click Plot.

Chlorine concentration
Duplicate this plot group to create the same plot for chlorine (Figure 4).

1 Right-click Particle concentration and choose Duplicate.

2 In the Settings window for 3D Plot Group, type Chlorine concentration in the Label 
text field.

Multislice 1
1 In the Model Builder window, expand the Chlorine concentration node, then click 

Multislice 1.

2 In the Settings window for Multislice, locate the Expression section.

3 In the Expression text field, type c_cl.
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Surface 1
1 In the Model Builder window, click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type c_cl.

4 In the Chlorine concentration toolbar, click Plot.

Duplicate this plot again and repeat the steps to plot the chloroform concentration 
c_chcl3. Compare with Figure 5.

Surface Average 1
Finally, create Figure 6.

1 In the Results toolbar, click More Derived Values and choose Average>

Surface Average.

2 In the Settings window for Surface Average, locate the Selection section.

3 From the Selection list, choose Filtered water outlet.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click next to Evaluate, then choose New Table.

T A B L E

1 Go to the Table window.

2 Click Table Graph in the window toolbar.

R E S U L T S

Table Graph 1
1 In the Model Builder window, under Results>1D Plot Group 5 click Table Graph 1.

2 In the Settings window for Table Graph, click to expand the Legends section.

3 Select the Show legends check box.

Concentration over time.
1 In the Model Builder window, under Results click 1D Plot Group 5.

Expression Unit Description

c_p/c_p0 1 Particle

c_cl/c_cl0 1 Chlorine

c_chcl3/c_chcl30 1 Chloroform
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2 In the Settings window for 1D Plot Group, type Concentration over time. in the 
Label text field.

3 Locate the Legend section. From the Position list, choose Upper left.
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