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S h a f t  w i t h  F i l l e t

Introduction

This model is of benchmark type, based on the example found in section 5.4.3 of Ref. 
1, and shows how to perform a high-cycle fatigue analysis for nonproportional loading 
using critical planes.

Model Definition

The geometry is a circular shaft with two different diameters, 10 mm and 20 mm. At 
the transition, between the two parts, there is a fillet with a radius of 3 mm.

Figure 1: Model geometry
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Two time-dependent loads are applied to the small end of the shaft: a transverse force, 
causing bending, and a twisting moment. As Figure 2 shows, the force varies between 
0 and 2.95 kN and the torque between 30.3 Nm and 30.3 Nm.

Figure 2: Variation of the bending force and twisting moment during one load cycle.

Compute the fatigue usage factor by analyzing the total stress distribution at times t1, 
t2 and t3. 

M A T E R I A L  P R O P E R T I E S

• Elastic data: Isotropic with E100 GPa, 0

• Fatigue data: The fatigue limit is known for two cases with pure axial loading. For 
pure tension it is 560 MPa (max1120 MPa, min0 MPa), and for fully 
reversed loading it is 700 MPa (max700 MPa, min700 MPa). This gives the 

t1 t2 t3

t1 t2 t3
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Findley parameters f440 MPa and k0.23 if Equation 13-16 on page 415 in the 
Structural Mechanics Module User’s Guide is applied.

C O N S T R A I N T S

The thick end of the bar is fixed.

L O A D S

• Bending load: The transverse force is evenly distributed as a shear traction over the 
small end.

• Torsional load: A shear stress in the circumferential direction is applied to the bar 
end. It is given as a linear variation with the radius in correspondence with analytical 
solutions for torsion.

Results and Discussion

Figure 3 shows the von Mises stresses for the bending load cases. The location for the 
maximum effective stress is at the surface of the fillet, at a radius slightly larger than the 
minimum radius of the shaft. The maximum effective stress can also be found at a 
diametrically opposite location. Here, the bending load gives rise to a compression 
stress of equal magnitude as the tension stress at the other side. Due to numerical 
reasons, the maximum stresses do not occur exactly in the xz-plane.

Figure 3: von Mises stress distribution from the bending load case.
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Figure 4 shows the effective stress distribution for the torsional load. You can find the 
maximum value along the surface of the fillet, where the shear stress in the 
circumferential direction is at a maximum.

Figure 4: von Mises stress distribution for the torsional load case.

In Figure 5 you can see that the highest value of the utilization factor, 0.962, is found 
where the positive bending stress is combined with the shear stress from torsion. Note 
that on the diametrically opposite side of the shaft, with the maximum compressive 
stress due to the bending, the utilization factor is only slightly increased compared to 
the surrounding areas.

Figure 5: Fatigue utilization factor.
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The history of each of the global stress components in the most critical point is shown 
in Figure 6. Because the peak stresses occur at a small distance up along the fillet and 
because, for numerical reasons, they are not found exactly in the plane  y0, all stress 
components are nonzero.

Figure 6: Histories for global stress components.

For the example in Ref. 1 the computed Findley parameter is 433 MPa, which gives a 
utilization factor of 0.984. This is slightly higher than the utilization factor computed 
by this model, which is 0.962. The difference is mainly due to the simplified approach 
of the referenced example, where only the normal stress component from the bending 
load and the shear stress component from the torsional load are considered. In reality, 
there are additional stress components, especially in the bending case. Also, the peak 
stress concentration does not occur at exactly the same location in the two load cases.

Modeling in COMSOL Multiphysics

Start by using the parametric solver to solve the static problem for the load cases of the 
maximum bending force and the maximum twisting moment, respectively. These are 
the two basic load cases that you can combine and use for the fatigue analysis.

Carry out the fatigue analysis in MATLAB by doing the following steps:

• Extract the stress distribution (stress tensor) for both basic load cases from the FEM 
structure of the model.
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• Set up the matrix containing the combinations of basic load cases which you can use 
for the fatigue analysis. The rows of this matrix correspond to the time instances you 
are analyzing, and the columns correspond to the basic load cases.

In this case the matrix is a 3x2 matrix. If you look at Figure 2 you can see that at 
time t1 both loads are zero, thus the first row has only zeros. At time t2 the bending 
force is at maximum, while the torque at minimum. You obtain the combined 
stresses by subtracting the solution of the twisting moment from that of the bending 
force. The second row of the matrix is thus 1 1. Both loads are at maximum at the 
third time, t3, which means that you can add the basic load cases and the third row 
of the matrix contains two ones.

• Run the fatigue analysis function hcfmultiax.

Reference

1. D, F. Socie and G.B. Marquis, Multiaxial Fatigue, SAE, 1999.

Model Library path: Structural_Mechanics_Module/Fatigue/
shaft_with_fillet

Note: This model requires MATLAB to run the fatigue script 
shaft_with_fillet_fatigue.m

Modeling Using the Graphical User Interface

This section describes how to solve the two basic load cases using COMSOL 
Multiphysics.

M O D E L  N A V I G A T O R

1 On the New page, select 3D from the Space dimension list.

2 From the Application Modes list, select Structural Mechanics Module>Solid, 

Stress-Strain>Static analysis.

3 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants and enter the following constants (the 
descriptions are optional); then click OK.

2 Choose Model Settings from the Physics menu to open the Model Settings dialog box.

3 Select MPa from the Base unit system list to use mm as length scale and MPa as stress 
unit. Click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by drawing a 2D plane and rotate it.

1 Select Work-Plane Settings from the Draw menu to open the Work-Plane Settings 
dialog box.

2 Click OK to create a 2D work plane in the xy-plane which is the default settings.

3 Select Axes/Grid Settings from the Options menu and give axis and grid settings 
according to the following table. On the Grid page, clear the Auto check box to enter 
the grid spacing. When done, click OK.

4 Click the Line button on the Draw toolbar. Click the left mouse button at (0, 0), 
then move the mouse to (0, 10) and click the left mouse button again.

5 Move the mouse to (25, 10) and click the left mouse button again.

6 Move the mouse to (25, 8) and click the left mouse button.

7 Click the 2nd Degree Bézier Curve button on the Draw toolbar.

8 Move the mouse to (25, 5) and click the left mouse button.

NAME EXPRESSION DESCRIPTION

M 30.3[N*m] Torque amplitude

R 5[mm] Radius where torque and force are applied

k M/(R^4*pi/2) Constant used in distributed moment calculation

param 1 Parameter used to control the load cases

F 2.95[kN] Maximum bending force

A pi*R^2 Area of surface where force is applied

AXIS GRID

x min -5 x spacing 1

x max 60 Extra x

y min -15 y spacing 1

y max 15 Extra y
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9 Move the mouse to (28, 5) and click the left mouse button.

10 Click the Line button on the Draw toolbar.

11 Move the mouse to (49, 5) and click the left mouse button.

12 Move the mouse to (49, 0) and click the left mouse button.

13 Click the right mouse button to form a 2D solid.

14 Select Revolve from the Draw menu to open the Revolve dialog box.

15 Select Axis direction through: Second point.

16 Enter x 1 y 0 as the coordinates of the Second point.

17 Click OK to close the Revolve dialog box and create the shaft.

P H Y S I C S  S E T T I N G S

Boundary Conditions
1 Select Boundary Settings from the Physics menu.

2 Specify boundary settings according to the following table; when done, click OK.

Subdomain Settings
1 Select Subdomain Settings from the Physics menu.

2 Specify subdomain settings according to the following table; when done, click OK.

M E S H  G E N E R A T I O N

1 Select Free Mesh Parameters from the Mesh menu to open the Free Mesh Parameters 
dialog box.

SETTINGS BOUNDARIES 1, 3, 5, 7 BOUNDARIES 21–24

Page Constraint Load

Constraint condition Fixed

Fx 0

Fy -z*k*(param>1.5)

Fz y*k*(param>1.5)-F/A*(param<1.5)

SETTINGS SUBDOMAIN 1

 Page Material

 Material model Isotropic

 E 100[GPa]

  0
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2 On the Subdomain page, type 1.2 in the Element growth rate edit field.

3 On the Boundary page, select Boundaries 11, 12, 14, and 16.

4 Enter 1 in the Maximum element size edit field. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Select Solver Parameters from the Solve menu to open the Solver Parameters dialog 
box.

2 Select Parametric in the Solver list.

3 Specify param in the Parameter name edit field.

4 Specify 1,2 in the Parameter values edit field.

5 Select Conjugate gradients from the Linear system solver list. Click OK.

6 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Select Plot Parameters from the Postprocessing menu.

2 Select 1 from the Parameter value list on the General page to plot the von Mises stress 
distribution from the bending.

3 Select 2 from the Parameter value list to plot the von Mises stress distribution from 
torsion.

Fatigue Analysis

This section describes how to solve the fatigue problem.

You have already solved the static bending and torsion load cases. 

• Select File>Export>FEM Structure as 'fem' from the File menu to export the FEM 
structure containing the static load cases to the command line.

• Run the script shaft_with_fillet_fatigue.m by typing 
shaft_with_fillet_fatigue and pressing Return.

The script shaft_with_fillet_fatigue.m is shown below.

% Compute all components of the stress tensor
[sxx, syy, szz, sxy, syz, sxz] = posteval(fem,'sx_smsld','sy_smsld',...
                                          'sz_smsld',...
                                          'sxy_smsld','syz_smsld',...
                                          'sxz_smsld',...
                                          'edim',2,'solnum','all','cont','on');
stress = zeros(6,size(sxx.d,2),size(sxx.d,1));
stress(1,:,:)=sxx.d';
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stress(2,:,:)=syy.d';
stress(3,:,:)=szz.d';
stress(4,:,:)=sxy.d';
stress(5,:,:)=syz.d';
stress(6,:,:)=sxz.d';

% Fatigue data for the material
params.f = 440;
params.k = 0.23;

% Combine the basic loadcases to form the fatigue loadcycle
lccomb = [0 0; 1 1; 1 -1];

% Resolution when searching for the critical plane
angle_step = 6; % degrees

% Compute the fatigue damage
[resval, sigma_max, delta_tau, worst_ind, s_history]= hcfmultiax(stress, ...
                   'lccomb', lccomb, 'anglestep', angle_step, 'params', params);

% Copy a postdata struct from the stress evaluation and assign the damage data
% to the value field (d)
findley_res = sxx;
findley_res.d(1,:) = resval;
figure(1);

% Plot the fatigue damage
postdataplot(findley_res,...
             'scenelight','on',...
             'campos',[244,-161,77],...
             'camtarget',[24.5,0,0],...
             'camva',9.5,...
             'title','Fatigue utilization factor');

% Plot the maximum normal stress in the critical plane
sigma_max_res = sxx;
sigma_max_res.d(1,:) = sigma_max;
figure(2);
postdataplot(sigma_max_res,...
             'scenelight','on',...
             'campos',[244,-161,77],...
             'camtarget',[24.5,0,0],...
             'camva',9.5,...
             'title','Maximum normal stress');

% Plot the shear stress in the critical plane
delta_tau_res = sxx;
delta_tau_res.d(1,:) = delta_tau;
figure(3);
postdataplot(delta_tau_res,...
             'scenelight','on',...
             'campos',[244,-161,77],...
             'camtarget',[24.5,0,0],...
             'camva',9.5,...
             'title','Shear stress amplitude');
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% Plot the stress history for all stress components at the point with
% maximum fatigue damage
x = 1:(size(s_history,2));
figure(4);
if isscript
  plot(x,s_history,'linestyle','cycle');
else
  plot(x,s_history);
end
legend('sxx','syy','szz','sxy','syz','sxz')
title('Stress history in critical point')
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