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F r i c t i o n  S t i r  We l d i n g

Introduction

Manufacturers use a modern welding method called friction stir welding to join 
aluminum plates. This model analyzes the heat transfer in this welding process. The 
model is based on a paper by M. Song and R. Kovacevic (Ref. 1).

In friction stir welding, a rotating tool moves along the weld joint and melts the 
aluminum through the generation of friction heat. The tool’s rotation stirs the melted 
aluminum such that the two plates are joined. Figure 1 shows the rotating tool and the 
aluminum plates being are joined.

Figure 1: Two aluminum plates being joined by friction stir welding.

The rotating tool is in contact with the aluminum plates along two surfaces: the tool’s 
shoulder, and the tool’s pin. The tool adds heat to the aluminum plates through both 
interfaces.

During the welding process, the tool moves along the weld joint. This movement 
would require a fairly complex model if you want to model the tool as a moving heat 
source. This example takes a different approach that uses a moving coordinate system 
that is fixed at the tool axis (Ref. 1 also takes this approach). After making the 
coordinate transformation, the heat transfer problem becomes a stationary 
convection-conduction problem that is straightforward to model.

The model includes some simplifications. For example, the coordinate transformation 
assumes that the aluminum plates are infinitely long. This means that the analysis 
neglects effects near the edges of the plates. Neither does the model account for the 
stirring process in the aluminum, which is very complex because it includes phase 
changes and material flow from the front to the back of the rotating tool.
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Model Definition

The model geometry is symmetric around the weld. It is therefore sufficient to model 
only one aluminum plate. The plate dimensions are 120 mm × 102 mm × 12.7 mm, 
surrounded by two infinite domains in the x direction. Figure 2 shows the resulting 
model geometry: 

Figure 2: Model geometry for friction stir welding.

The following equation describes heat transfer in the plate. As a result of fixing the 
coordinate system in the welding tool, the equation includes a convective term in 
addition to the conductive term. The equation is

where k represents thermal conductivity, ρ is the density, Cp denotes specific heat 
capacity, and u is the velocity.

The model sets the velocity to u = 1.59·10−3 m/s in the negative x direction.

The model simulates the heat generated in the interface between the tool’s pin and the 
workpiece as a surface heat source (expression adapted from Ref. 2):

Here μ is the friction coefficient, rp denotes the pin radius, ω refers to the pin’s angular 
velocity (rad/s), and  is the average shear stress of the material. As indicated, the 
average shear stress is a function of the temperature; for this model, you approximate 
this function with an interpolation function determined from experimental data given 
in Ref. 1 (see Figure 4).
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Additionally, heat is generated at the interface between the tool’s shoulder and the 
workpiece; the following expression defines the local heat flux per unit area (W/m2) 
at the distance r from the center axis of the tool:

Here Fn represents the normal force, As is the shoulder’s surface area, and Tmelt is 
aluminum’s melting temperature. As before, μ is the friction coefficient and ω is the 
angular velocity of the tool (rad/s).

Above the melting temperature of aluminum, the friction between the tool and the 
aluminum plate is very low. Therefore, the model sets the heat generation from the 
shoulder and the pin to zero when the temperature is equal to or higher than the 
melting temperature.

Symmetry will be assumed along the weld joint boundary.

The upper and lower surfaces of the aluminum plates lose heat due to natural 
convection and surface-to-ambient radiation. The corresponding heat flux expressions 
for these surfaces are

where hup and hdown are heat transfer coefficients for natural convection, T0 is an 
associated reference temperature, ε is the surface emissivity, σ is the Stefan-Boltzmann 
constant, and Tamb is the ambient air temperature. 

The modeling of an infinite domain on the left-hand side, where the aluminum leaves 
the computational domain, makes sure that the temperature is in equilibrium with the 
temperature at infinity through natural convection and surface-to-ambient radiation. 
You therefore set the boundary condition to insulation at that location.

You can compute values for the heat transfer coefficients using empirical expressions 
available in the heat-transfer literature, for example, Ref. 3. In this model, use the 
values hup = 12.25 W/(m2·K) and hdown = 6.25 W/(m2·K)

qshoulder r T,( )
μFn As⁄( )ωr ; T Tmelt<

0 ; T Tmelt≥
⎩
⎪
⎨
⎪
⎧

=

qup hup T0 T–( ) εσ Tamb
4 T4

–( )+=

qdown hdown T0 T–( ) εσ Tamb
4 T4

–( )+=
F R I C T I O N  S T I R  W E L D I N G  |  3



friction_welding_sbs.book  Page 4  Friday, November 28, 2008  2:58 PM
Results and Discussion

Figure 3 shows the resulting temperature field. Consider this result as what you would 
see through a window fixed to the moving welding tool.

Figure 3: Temperature field in the aluminum plate.

The temperature is highest where the aluminum is in contact with the rotating tool. 
Behind the tool, the process transports hot material away, while in front of the tool, 
new cold material enters.
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Model Library path: Heat_Transfer_Module/Process_and_Manufacturing/
friction_welding

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the New tab. In the Space dimension list select 3D.

2 From the list of application modes select 
Heat Transfer Module>General Heat Transfer>Steady-state analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
From the Options menu, select Constants. Define the following names, expressions, and 
(optionally) descriptions; when done, click OK.

NAME EXPRESSION DESCRIPTION

T0 300[K] Reference temperature

T_melt 933[K] Workpiece melting temperature

rho_pin 7800[kg/m^3] Pin density

k_pin 42[W/(m*K)] Thermal conductivity

Cp_pin 500[J/(kg*K)] Specific heat capacity

h_upside 12.25[W/(m^2*K)] Heat transfer coefficient, upside

h_downside 6.25[W/(m^2*K)] Heat transfer coefficient, downside

epsilon 0.3 Surface emissivity

u_weld 1.59[mm/s] Welding speed

mu 0.4 Friction coefficient

n 637[1/min] Rotation speed (RPM)

omega 2*pi[rad]*n Angular velocity (rad/s)

F_n 25[kN] Normal force

r_pin 6[mm] Pin radius

r_shoulder 25[mm] Shoulder radius

A_s pi*(r_shoulder^2
-r_pin^2)

Shoulder surface area
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Functions
Next, define an interpolation function for the aluminum yield stress, , as a function 
of the temperature, T, based on experimental material data listed in Ref. 1.

1 From the Options menu open the Functions dialog box.

2 Click New.

3 In the New Function dialog box, type Ybar in the Function name edit field.

4 Select the Interpolation option button, then click OK.

5 Back in the Functions dialog box, leave the default settings for Interpolation method 
and Extrapolation method. In the x and f(x) columns enter the following data:

The x values are temperatures (in kelvin) and the f values corresponding yield 
stresses (in MPa) for 6061-T6 aluminum.

6 When finished, click Plot to view the resulting interpolation function (Figure 4), 
then click OK to close the Functions dialog box.

Figure 4: Yield stress (MPa) vs. temperature (K) for 6061-T6 aluminum.

x 311 339 366 394 422 450 477 533 589 644

f(x) 241 238 232 223 189 138 92 34 19 12

Y
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G E O M E T R Y  M O D E L I N G

1 Create the aluminum plate. From the Draw menu, select Block.

2 In the dialog box that appears, go to the Length area and enter the settings in the 
following table; when done, click OK.

3 Repeat Steps 1 and 2 to draw another block using the settings in the following table:

4 In the Axis base point area, type -50e-3 in the x edit field. Click OK.

5 To create a third block of the same dimensions as the one you just created, press 
Ctrl+C and then press Ctrl+V. In the Paste dialog box that appears, type 170e-3 in 
the x edit field, then click OK.

6 Click the Zoom Extents button on the Main toolbar.

7 Go to the Draw menu and select Work-Plane Settings.

8 On the Quick page, click the x-y option button, then in the z edit field enter 
12.7e-3. Click OK.

9 Click the Zoom Extents button on the Main toolbar.

10 Press the Shift key and click the Ellipse/Circle (Centered) button on the Draw toolbar.

11 In the dialog box that appears, enter the following circle properties; when done, 
click OK:

OBJECT DIMENSIONS EXPRESSION

X 120e-3

Y 102e-3

Z 12.7e-3

OBJECT DIMENSIONS EXPRESSION

X 50e-3

Y 102e-3

Z 12.7e-3

OBJECT DIMENSIONS EXPRESSION

Radius 25e-3

Base Center

x-position 61.5e-3

y-position 0
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12 In the same manner, create a second circle with the following properties:

13 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

14 In the dialog box that appears, enter the following rectangle properties; when done, 
click OK:

15 Create another rectangle with the following properties:

16 Select the circle C1 and the rectangle R1, then click the Difference button on the 
Draw toolbar.

17 Similarly, select the circle C2 and the rectangle R2, then click the Difference button.

18 Select the object CO1, then from the Draw menu select Embed.

19 In the dialog that appears, click OK.

20 Return to the Geom2 geometry.

21 Select the object CO2, then from the Draw menu select Extrude.

22 In the dialog that appears, find the Distance edit field and type -12.7e-3.

23 Click OK.

OBJECT DIMENSIONS EXPRESSION

Radius 6e-3

Base Center

x-position 61.5e-3

y-position 0

OBJECT DIMENSIONS EXPRESSION

Width 50e-3

Height 25e-3

Base Corner

x-position 36.5e-3

y-position -25e-3

OBJECT DIMENSIONS EXPRESSION

Width 12e-3

Height 6e-3

Base Corner

x-position 55.5e-3

y-position -6e-3
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24 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Boundary Expressions
1 From the Options menu, select Expressions>Boundary Expressions.

2 Select Boundary 11, then enter the following expressions.

3 Select Boundaries 12 and 16, then enter the following expressions (on the third line 
of the table); when finished, click OK.

Note: The boundary expressions defined above include a smoothed step function, 
flc1hs, which models that the generation of friction heat is zero above the melting 
temperature of aluminum. Using this function is computationally more stable than 
multiplying the expressions by the logical expression (T<T_melt).

Subdomain Settings
1 Choose Physics>Subdomain Settings.

2 Select Subdomains 1, 2 and 4, then click the Load button.

3 From the Materials list, select Basic Material Properties>Aluminum, then click OK.

4 Select Subdomain 3 and enter the following settings:

5 Click the Convection tab and select Subdomains 1, 2 and 4.

6 Select the Enable convective heat transfer check box.

NAME EXPRESSION

R sqrt((x-0.0615)^2+y^2)

q_shoulder (mu*F_n/A_s)*(R*omega)*flc1hs((T_melt-T)[1/K],5)

NAME EXPRESSION

q_pin mu/sqrt(3*(1+mu^2))*(r_pin*omega)*Ybar(T[1/K])[MPa]* 
flc1hs((T_melt-T)[1/K],5)

PROPERTY VALUE

 k (isotropic) k_pin

 ρ rho_pin

 Cp Cp_pin
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7 In the Matter state list, select Solid.

8 In the leftmost u edit field for the x velocity, type -u_weld.

9 Select Subdomains 1 and 4, and click the Infinite Elements tab.

10 From the Type of infinite element list, select Cartesian. Then select the Stretched in x 

direction check box.

11 Enter the following properties in the x0, y0, and z0 edit fields:

12 Select all subdomains and click the Init tab. Type T0 in the T(t0) edit field for the 
initial value.

13 Click OK.

Boundary Settings
1 From the Physics menu, select Boundary Settings.

2 Select the Interior boundaries check box.

3 Enter settings as in the following table; when finished, click OK.

For the boundaries not mentioned in the table, the default setting (Insulation/
Symmetry) applies.

PROPERTY VALUE

x0 61.5e-3

y0 3e-3

z0 6e-3

SETTINGS BOUNDARY 1 BOUNDARIES 3, 
8, 20

BOUNDARY 4, 
9, 21

BOUNDARY 11 BOUNDARIES 
12, 16

BOU

Type Insulation/
Symmetry

Heat flux Heat flux Heat flux Heat source/
sink

Tem

q0 q_shoulder q_pin

h h_downside h_upside 0

Tinf T0 T0 273.15

T0 T0

Radiation 
type

Surface-to- 
ambient

Surface-to- 
ambient

None

 ε epsilon epsilon

Tamb T0 T0
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M E S H  G E N E R A T I O N

From the Mesh menu, select Initialize Mesh.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

2 Click the Stationary tab.

3 Type 60 in the Maximum number of iterations edit field.

4 Click OK.

5 From the Solve menu, choose Solve Problem.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows a slice plot of the temperature field. To create Figure 3, which 
shows a slice plot and some temperature isosurfaces, follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 Go to the Slice page and find the Slice positioning area.

3 In the Number of levels edit field for x levels, change the value to 0.

4 From the Color table list in the Slice color area, select Thermal.

5 In the Vector with coordinates edit field for z levels, type 1e-3.

6 Click Apply.

7 On the Isosurface page, select the Isosurface plot check box.

8 In the Vector with isolevels edit field, type range(300,20,980).

9 From the Color table list in the Isosurface color area, select Thermal.

10 Clear the Color legend check box.

Click OK.
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