Introduction to COMSOL Multiphysics®
Introduction to COMSOL Multiphysics

Protected by U.S. Patents 7,519,518; 7,596,474; 7,623,991. Patents pending.

This Documentation and the Programs described herein are furnished under the COMSOL Software License Agreement (www.comsol.com/sla) and may be used or copied only under the terms of the license agreement. COMSOL, COMSOL Multiphysics, Capture the Concept, COMSOL Desktop, and LiveLink are either registered trademarks or trademarks of COMSOL AB. All other trademarks are the property of their respective owners, and COMSOL AB and its subsidiaries and products are not affiliated with, endorsed by, sponsored by, or supported by those trademark owners. For a list of such trademark owners, see www.comsol.com/tm.

Version: May 2013

Contact Information

Visit the Contact Us page at www.comsol.com/contact to submit general inquiries, contact Technical Support, or search for an address and phone number. You can also visit the Worldwide Sales Offices page at www.comsol.com/contact/offices for address and contact information.

If you need to contact Support, an online request form is located at the COMSOL Access page at www.comsol.com/support/case.

Other useful links include:

- Support Center: www.comsol.com/support
- Download COMSOL: www.comsol.com/support/download
- Product Updates: www.comsol.com/support/updates
- COMSOL Community: www.comsol.com/community
- Events: www.comsol.com/events
- COMSOL Video Center: www.comsol.com/video
- Support Knowledge Base: www.comsol.com/support/knowledgebase

Part No. CM010004
## Contents

Introduction ..................................................... 1  
The COMSOL Desktop ......................................... 2  
Example 1: Structural Analysis of a Wrench ............... 20  
Example 2: The Busbar—A Multiphysics Model ............ 42  
Advanced Topics ................................................. 69  
  Parameters, Functions, Variables and Model Couplings . 69  
  Material Properties and Material Libraries ............... 73  
  Adding Meshes .................................................. 75  
  Adding Physics .................................................. 77  
  Parametric Sweeps ............................................. 96  
  Parallel Computing ............................................ 104  
Appendix A—Building a Geometry .............................. 107  
Appendix B—Keyboard and Mouse Shortcuts ................. 121  
Appendix C—Language Elements and Reserved Names .... 124  
Appendix D—File Formats ....................................... 136  
Appendix E—Connecting with LiveLink™ Add-Ons .......... 142
Introduction

Computer simulation has become an essential part of science and engineering. Digital analysis of components, in particular, is important when developing new products or optimizing designs. Today a broad spectrum of options for simulation is available; researchers use everything from basic programming languages to various high-level packages implementing advanced methods. Though each of these techniques has its own unique attributes, they all share a common concern: Can you rely on the results?

When considering what makes software reliable, it’s helpful to remember the goal: you want a model that accurately depicts what happens in the real world. A computer simulation environment is simply a translation of real-world physical laws into their virtual form. How much simplification takes place in the translation process helps to determine the accuracy of the resulting model.

It would be ideal, then, to have a simulation environment that included the possibility to add any physical effect to your model. That is what COMSOL® is all about. It’s a flexible platform that allows users to model all relevant physical aspects of their designs. Expert users can go deeper and use their knowledge to develop customized solutions, applicable to their unique circumstances. With this kind of all-inclusive modeling environment, COMSOL gives you the confidence to build the model you want with real-world precision.

Certain characteristics of COMSOL become apparent with use. Compatibility stands out among these. COMSOL requires that every type of simulation included in the package has the ability to be combined with any other. This strict requirement mirrors what happens in the real world. For instance, in nature, electricity is always accompanied by some thermal effect; the two are fully compatible. Enforcing compatibility guarantees consistent multiphysics models and the knowledge that you never have to worry about creating a disconnected model again.

Another noticeable trait of the COMSOL platform is adaptability. As your modeling needs change, so does the software. If you find yourself in need of including another physical effect, you can just add it. If one of the inputs to your model requires a formula, you can just enter it. Using tools like parameterized geometry, interactive meshing and custom solver sequences, you can quickly adapt to the ebbs and flows of your requirements.

The flexible nature of the COMSOL environment facilitates further analysis by making “what-if” cases easy to set up and run. You can take your simulation to the production level by optimizing any aspect of your model. Parameter sweeps and target functions can be executed directly in the user interface. From start to finish, COMSOL is a complete problem-solving tool.
The COMSOL Desktop

- **MODEL BUILDER WINDOW**—The modeling process is controlled through the Model Builder window with a Model Tree together with associated toolbar buttons.

- **MODEL WIZARD WINDOW**—Guided steps to set space dimension, physics, and study types.

- **MODEL LIBRARY WINDOW**—Easy access to COMSOL and user model libraries.

- **MENU BAR**—Use these menus for access to functionality such as file load/save, selections, desktop layout, preferences, and documentation.

- **MAIN TOOLBAR**—The main toolbar has standard buttons for frequently used actions such as load/save, print, and help. It adapts to the active Model Tree node.

- **INITIAL MODEL TREE**

- **MODEL BUILDER TOOLBAR**
INFORMATION WINDOWS—The Information windows will display vital model information during the simulation, such as the solution time, solution progress, mesh statistics, and solver logs, as well as Results Tables, if any.

GRAPHICS WINDOW TOOLBAR

GRAPHICS WINDOW—The Graphics window presents interactive graphics for Geometry, Mesh, and Results. Interactions include rotating, panning, zooming, and selecting. It is the default window for most Results and visualizations.
The Desktop on the previous pages is what you see when you first start COMSOL. The COMSOL Desktop® provides a complete and integrated environment for physics modeling and simulation. You can customize it to your own needs. The Desktop windows can be resized, moved, docked, and detached. Any changes you make to the layout will be saved when you close the session and used again the next time you open COMSOL. As you build your model, additional windows and widgets will be added. (See page 16 for an example of a more developed desktop). Among the possible windows are the following:

**Settings Window**

This is the main window for entering all of the specifications of the model, the dimensions of the geometry, the properties of the materials, the boundary conditions and initial conditions, and any other information that the solver will need to carry out the simulation.

**Plot Windows**

These are the windows for graphical output. In addition to the Graphics window, Plot windows are used for Results visualization. Several Plot windows can be used to show multiple results simultaneously. A special case is the Convergence Plot.
window, an automatically generated Plot window that displays a graphical indication of the convergence of the solution process while a model is running.

**Information Windows**

These are the windows for non-graphical information. They include:

- **Messages**: Various information about events of the current COMSOL session is displayed in this window.
- **Log**: Information from the solver such as number of degrees of freedom, solution time, and solver iteration data.
- **Progress**: Progress information from the solver as well as stop buttons.
- **Table**: Numerical data in table format as defined in the Results branch.
- **External Process**: Provides a control panel for cluster, cloud, and batch jobs.

**Other Windows**

- **Material Browser**: Access the material property libraries.
- **Model Library Update**: An update service for downloading new model tutorials as well as update existing models to the Model Library.
- **Selection List**: A list of geometry objects, domains, boundaries, edges, and points that are currently available for selection.

**Progress Bar with Cancel Button**

The Progress Bar with a button for canceling the current computation, if any, is located in the lower right-hand corner of the COMSOL Desktop window.

**Dynamic Help**

The Help window provides context dependent help texts about windows and Model Tree nodes. If you have the Help window open in your desktop (by typing F1 for example) you will get dynamic help (in English only) when you click a node or a window. From the Help window you can search for other topics such as menu items.
Preferences

Preferences are settings that affect the modeling environment. Most are persistent between modeling sessions, but some are saved with the model. You access Preferences from the Options menu.

In the Preferences window you can change settings such as graphics rendering, number of displayed digits for Results, or maximum number of CPU cores used for computations. Take a moment to browse your current settings to familiarize yourself with the different options.

There are three graphics rendering options available: OpenGL, Direct X, and Software Rendering. Direct X is not available on Mac OS X or Linux but is available on Windows if you choose to install the Direct X runtime libraries during installation. If your computer doesn’t have a dedicated graphics card, you may have to switch to Software Rendering for slower but fully functional graphics. A list of recommended graphics cards can be found at:

http://www.comsol.com/products/requirements/

If you cannot use the arrow-keys to step up and down the Preferences list, you should change the Rendering selection in the Graphics Preferences.
The Model Builder and the Model Tree

The Model Builder is the tool where you define the model: how to solve it, the analysis of results, and the reports. You do that by building a Model Tree. You build the tree by starting with a default Model Tree, adding nodes, and editing the node settings.

All of the nodes in the default Model Tree are top-level parent nodes. You can right-click on them to see a list of child nodes, or subnodes, that you can add beneath them. This is the means by which nodes are added to the tree. When you left-click on a child node, then you will see its node settings in the Settings window. It is here that you can edit node settings.

It is worth knowing that if you have the Help window open (which is achieved either by clicking Help in the menu bar, or by typing function key F1), then you will also get dynamic help (in English only) when you click on a node.

The Root, Global Definitions and Results Nodes

A Model Tree always has a Root node (initially labeled Untitled.mph), a Global Definitions node, and a Results node. The label on the Root node is the name of the multiphysics model file, or MPH file, that this model is saved to on the disk. The Root node has settings for author name, default unit system, and more.

The Global Definitions node is where you define parameters, variables, functions, and computations that can be used throughout the Model Tree. They can be used, for example, to define the values and functional dependencies of material properties, forces, geometry, and other relevant features. The Global Definitions node itself has no settings, but its child nodes have plenty.
The Results node is where you access the solution after performing a simulation and where you find tools for processing the data. The Results node initially has five subnodes:

- **Data Sets**: contains a list of solutions you can work with.
- **Derived Values**: defines values to be derived from the solution using a number of postprocessing tools.
- **Tables**: a convenient destination for the Derived Values, or for Results generated by probes that monitor the solution in real-time while the simulation is running.
- **Export**: defines numerical data, images, and animations to be exported to files.
- **Reports**: contains automatically generated or custom reports about the model in HTML or Microsoft Word format.

To these five default subnodes you may also add additional Plot Group subnodes that define graphs to be displayed in the Graphics window or in Plot windows. Some of these may be created automatically, depending on the type of simulations you are performing, but you may add additional figures by right-clicking on the Results node and choosing from the list of plot types.

### The Model and Study Nodes

In addition to the three nodes just described, there are two additional top-level node types: Model nodes and Study nodes. These are usually created by the Model Wizard when you create a new model. After using the Model Wizard to specify what type of Physics you are modeling, and what type of Study (e.g. steady-state, time-dependent, frequency-domain, or eigenfrequency analysis) you will carry out, the Wizard automatically creates one node of each type and shows you their contents.
It is also possible to add additional Model and Study nodes as you develop the model. Since there can be multiple Model and Study nodes and it would be confusing if they all had the same name, these types of nodes can be renamed to be descriptive of their individual purposes.

If a model has multiple Model nodes, they can be coupled together to form a more sophisticated sequence of simulation steps.

Note that each Study node may carry out a different type of computation, so each one has a separate Compute button.

To be more specific, suppose that you build a model that simulates a coil assembly that is made up of two parts, a coil and a coil housing. You could create two Model nodes, one of which modeled the coil and the other of which modeled the coil housing. You would then rename each of the nodes with the name of the object that it modeled. Similarly, you might also create two Study nodes, the first simulating the stationary, or steady-state, behavior of the assembly and the second simulating the frequency response. You could rename these two nodes to Stationary and Frequency Domain. When the model is completed, it could be saved to a file named *Coil Assembly.mph*. At that point, the Model Tree in the Model Builder would look like the figure above.

In this figure, the Root node is named Coil Assembly.mph, indicating the file in which the model is saved. The Global Definitions node and the Results node each have their default name. In addition there are two Model nodes and two Study nodes with the names chosen in the previous paragraph.
PARAMETERS, VARIABLES AND SCOPE

Parameters

Parameters are user-defined constant scalars that are usable throughout the Model Tree. (That is to say, they are “global” in nature.) Important uses are:

- Parameterizing geometric dimensions
- Specifying mesh element sizes
- Defining parametric sweeps (i.e. simulations that are repeated for a variety of different values of a parameter).

A Parameter Expression can contain numbers, parameters, built-in constants, functions with Parameter Expressions as arguments, and unary and binary operators. For a list of available operators, see “Appendix C—Language Elements and Reserved Names” on page 124. Because these expressions are evaluated before a simulation begins, Parameters may not depend on the time variable t. Likewise, they may not depend on spatial variables, like x, y, or z, nor on the dependent variables that your equations are solving for.

It is important to know that the names of Parameters are case-sensitive.

You define Parameters in the Model Tree under Global Definitions.
Variables

Variables can be defined either in the Global Definitions node or in the Definitions subnode of any Model node. Naturally, the choice of where to define the variable depends upon whether you want it to be global (i.e., usable throughout the Model Tree) or locally defined within a single one of the Model nodes. Like a Parameter Expression, a Variable Expression may contain numbers, parameters, built-in constants, and unary and binary operators. However, it may also contain Variables, like \( t, x, y, \) or \( z \), functions with Variable Expressions as arguments, and dependent variables that you are solving for as well as their space and time derivatives.

Scope

The “scope” of a Parameter or Variable is a statement about where it may be used in an expression. As we have said, all Parameters are defined in the Global Definition node of the model tree. This means that they are global in scope and can be used throughout the Model Tree.

A Variable may also be defined in the Global Definitions node and have global scope, but they are subject to limitations other than their scope. For example, Variables may not be used in Geometry, Mesh, or Study nodes (with the one exception that a Variable may be used in an expression that determines when the simulation should stop).

A Variable that is defined, instead, in the Definitions subnode of a Model node has local scope and is intended for use in that particular Model (but, again, not in Geometry or Mesh nodes). They may be used, for example, to specify material properties in the Materials subnode or to specify boundary conditions or interactions. It is sometimes valuable to limit the scope of the variable to only a certain part of the geometry, such as certain boundaries. For that purpose, provisions are made in the Settings for a Variable definition to apply the definition either to the entire geometry of the Model, or only to certain Domains, Boundaries, Edges, or Points.
The picture below shows the definition of two Variables, \( q_{\text{pin}} \) and \( R \), in which the scope is being limited to just two boundaries identified by numbers 15 and 19.

Similarly, they could have been defined only on selected Domains, Edges, or Points. Such Selections can optionally be named and then referenced elsewhere in a model, such as when defining material properties or boundary conditions that will use the Variable. To give a name to the Selection, click on the Create Selection button \( (\mathbb{3}) \) to the right of the Selection list.

Although Variables defined in the Definitions subnode of a Model node are intended to have local scope, they can still be accessed outside of the Model node in the Model Tree by being sufficiently specific about their identity. This is done by using a “dot-notation” in which the Variable name is preceded by the name of the Model node in which it is defined and they are joined by a “dot.” In other words, if the Variable named \( \text{foo} \) is defined in a Model node named \( \text{MyModel} \), then this variable may be accessed outside of the Model node by using \( \text{MyModel.foo} \). This can be useful, for example, when you want to use the variable to make plots in the Results node.
Built-in Constants, Variables, and Functions

COMSOL comes with many built-in constants, variables, and functions. They have reserved names that cannot be redefined by the user. If you use a reserved name for a user-defined variable, parameter, or function, the text where you enter the name will turn orange (a warning) or red (an error) and you will get a tooltip message if you select the text string.

Some important examples are:

- Mathematical constants such as $\pi$ (3.14...) or the imaginary unit $i$ or $j$
- Physical constants such as $g_{\text{const}}$ (acceleration of gravity), $c_{\text{const}}$ (speed of light), or $R_{\text{const}}$ (universal gas constant)
- The time variable $t$
- First and second order derivatives of the Dependent variables (the solution) whose names are derived from the spatial coordinate names and Dependent variable names (which are user-defined variables)
- Mathematical functions such as $\cos$, $\sin$, $\exp$, $\log$, $\log_{10}$, and $\sqrt{}$

See “Appendix C—Language Elements and Reserved Names” on page 124 for more information.

The Model Library

The Model Library is a collection of Model MPH-files with accompanying documentation that includes a theoretical background and step-by-step instructions. Each physics-based COMSOL Module comes with its own set of
Model Library examples. You can use the step-by-step instructions and the Model MPH-files as a template for your own modeling and applications.

To open the Model Library, select View>Model Library ( ) from the main menu, and then search by model name or browse under a module folder name. Click to highlight any model of interest, and select Open Model and PDF to open both the model and the documentation explaining how to build the model. Alternatively, click the Help button ( ) or select Help>Documentation in COMSOL to search by model name or browse by module.

The Model Library is updated on a regular basis by COMSOL. Choose View>Model Library Update ( ) to update the model library. This connects you to COMSOL’s Model Update website where you can access the latest models and model updates. This may typically include models that have been added or improved since the latest product release.

The MPH-files in the COMSOL Model Library can have two formats—Full MPH-files or Compact MPH-files.

- Full MPH-files include all meshes and solutions. In the Model Library these models appear with the icon. If the MPH-file’s size exceeds 25MB, a
tooltip with the text “Large file” and the file size appears when you position the cursor at the model’s node in the Model Library tree.

Compact MPH-files include all settings for the model but have no built meshes and solution data to save file size. You can open these models to study the settings and to mesh and re-solve the models. It is also possible to download the full versions—with meshes and solutions—of most of these models through Model Library Update. In the Model Library such models appear with the icon. If you position the cursor at a compact model in the Model Library window, a No solutions stored message appears. If a full MPH-file is available for download, the corresponding node’s context menu includes a Model Library Update item.

The following spread shows an example of a customized Desktop with additional windows.
The COMSOL Desktop

The COMSOL Desktop environment is designed to facilitate the creation, solution, and analysis of complex physics simulations. The interface is divided into several key sections:

**Model Builder Window**—The modeling process is controlled through the Model Builder window with a Model Tree together with associated toolbar buttons.

**Model Tree**—The Model Tree gives an overview of the model and all the functionality and operations needed for building and solving a model as well as processing the results.

**Settings Window**—Click any node to see its associated settings window displayed next to the Model Builder.

**Model Library Window**—Easy access to COMSOL and user model libraries.

**Plot Window**—The Plot window visualizes results quantities, probes, and convergence plots. Several Plot windows can be used to show multiple results simultaneously.

**Information Windows**—The Information windows will display vital model information during the simulation such as solution time, solution progress, mesh statistics, and solver logs, as well as Results Tables, if any.

**Menu Bar**—Use these menus for access to functionality such as file load/save, selections, desktop layout, preferences, and documentation.

**Main Toolbar**—The main toolbar has standard buttons for frequently used actions such as load/save, print, and help. It adapts to the active Model Tree node.
GRAPHICS WINDOW—The Graphics window presents interactive graphics for Geometry, Mesh, and Results. Interactions include rotating, panning, zooming, and selecting. It is the default window for most Results visualizations.

DYNAMIC HELP—Continuously updated with online access to the Knowledge Base and Model Gallery. The Help window enables easy browsing with extended search functionality.

PROGRESS BAR WITH CANCEL BUTTON
Workflow and Sequence of Operations

In the Model Builder window of this example, every step of the modeling process, from defining global variables to the final report of results, is displayed in the Model Tree.

From top to bottom, the Model Tree defines an orderly sequence of operations. In the following branches of the Model Tree, node order makes a difference and you can change the sequence of operations by moving the nodes up or down the Model Tree:

- Geometry
- Material
- Physics
- Mesh
• Study
• Plot Groups

In the Model Definitions branch of the tree, the ordering of the following node types also makes a difference:
• Perfectly Matched Layers
• Infinite Elements

Nodes may be reordered by these methods:
• Drag-and-drop,
• Right-clicking the node and selecting Move Up or Move Down, or
• Pressing Ctrl + up-arrow or Ctrl + down-arrow.

In other branches, the ordering of nodes is not significant with respect to the sequence of operations, but some nodes can be reordered for readability. Child nodes to Global Definitions is one such example.

You can view the sequence of operations presented as program code statements by saving the model as a Model M-file or as a Model Java-file after having selected Reset History in the File menu. (Note: the model history keeps a complete record of the changes you make to a model as you build it. As such, it includes all your corrections, changes of parameters and boundary conditions, modifications of solver method, etc. Resetting this history removes all of the overridden changes and leaves a clean copy of the most recent form of the model steps.)

As you work with the COMSOL Desktop and the Model Builder you will grow to appreciate the organized and streamlined approach. But any description of a user interface is inadequate until you try it for yourself. So, in the next chapters you are invited to work through two examples to familiarize yourself with the software.
Example 1: Structural Analysis of a Wrench

This simple example requires none of the add-on products to COMSOL Multiphysics. For more fully-featured structural mechanics models, see the Model Library of the Structural Mechanics Module.

At some point in your life, it is likely you have tightened a bolt using a wrench. This exercise takes you through a structural mechanics model that analyzes this basic task from the perspective of structural integrity of the wrench subjected to a worst-case loading.

The wrench is, of course, made from steel, a ductile material. If the applied torque is too high, the tool will be permanently deformed due to the steel’s elastoplastic behavior when pushed beyond its yield stress level. To analyze whether the wrench handle is appropriately dimensioned, you will check if the mechanical stress level is within the yield stress limit.

This tutorial gives a quick introduction to the COMSOL workflow. It starts with opening the Model Wizard and adding a physics option for solid mechanics. Then a geometry is imported and the Material Browser is opened to add steel as the choice of material. You then explore the other key steps in creating a model by defining a parameter and boundary condition for the load, selecting geometric entities in the Graphics window, defining the Mesh and Study, and finally examining the results numerically and through visualization.

If you prefer to practice with a more advanced model, read this section to familiarize yourself with some of the key features, and then go to the tutorial “Example 2: The Busbar—A Multiphysics Model” on page 42.
To start the software, double-click the COMSOL icon on the desktop which will take you to the Model Wizard. Or when COMSOL is already open, you can start the Model Wizard in one of these three ways:
- Click the New button on the main toolbar
- Select File > New from the main menu
- Right-click the root node and select Add Model

The Model Wizard, visible to the right of the Model Builder, will guide you through the first steps of setting up a model. The first window lets you select the dimension of the modeling space.

In the Select Space Dimension window, the 3D button is selected by default. Click Next.

In Add Physics, select Structural Mechanics > Solid Mechanics (solid). Click Next.

With no add-on modules, Solid Mechanics is the only physics user interface available in the Structural Mechanics folder. In the picture to the right, the Structural Mechanics folder is shown as it looks when all add-on modules are available.
4 Click Stationary under Preset Studies. Click the Finish button. Preset Studies have solver and equation settings adapted to the selected physics: in this example, Solid Mechanics. A Stationary study is used in this case—there is no time-variation of loads or material properties. Any selection from the Custom Studies branch needs manual settings.

**Geometry**

This tutorial uses a geometry that was previously created and stored on COMSOL’s native CAD format .mphbin. To learn how to build your own geometry, see “Appendix A—Building a Geometry” on page 107.

**File Locations**

The location of the Model Library that contains the model file used in this exercise varies based on the software installation and operating system. On Windows, the file path will be similar to C:\Program Files\COMSOL\COMSOL43b\models\.
1 In the Model Builder window, under Model 1, right-click Geometry 1 and select Import.

![Model Builder](image)

2 In the Import settings window, from the Geometry import list, select COMSOL Multiphysics file.

![Import settings](image)

3 Click Browse and locate the file `wrench.mphbin` in the Model Library folder of the COMSOL installation folder. Its default location on Windows is

```
C:\Program Files\COMSOL\COMSOL43b\models\COMSOL_Multiphysics\Structural_Mechanics\wrench.mphbin
```

Double-click to add or click Open.
4 Click Import to display the geometry in the Graphics window.

5 Click the wrench geometry in the Graphics window and experiment with moving it around. As you click and right-click the geometry, it changes color. Click the Zoom In, Zoom Out, Go to Default 3D View, Zoom Extents, and Transparency buttons on the toolbar to see what happens to the geometry:
- To rotate the model, left-click and drag it in the Graphics window.
- To move it, right-click and drag.
- To zoom in and out, center-click (and hold) and drag.

Also see “Appendix B—Keyboard and Mouse Shortcuts” on page 121 for additional information.

The imported model has two parts, or domains, corresponding to the bolt and the wrench. In this exercise, the focus will be on analyzing the stress in the wrench.
**Materials**

The Materials node stores the material properties for all physics and all domains in a Model node. Use the same generic steel material for both the bolt and tool. Here is how to choose it in COMSOL.

1. Open the Material Browser.
   
   You open the Material Browser in either of these two ways:
   - Right-click Materials in the Model Builder and select Open Material Browser.
   - Use the Menu Bar to select View > Material Browser.

2. In the Material Browser, under Materials, expand the Built-In folder. Scroll down to find Structural Steel, right-click and select Add Material to Model.
Examine the Material Contents section to see the properties that are available and will be used by the Physics in the simulation (indicated by green check marks).

Also see the busbar tutorial sections “Materials” on page 49 and “Customizing Materials” on page 73 to learn more about working with the Material Browser.

Global Definitions

You will now define a global parameter specifying the load applied to the wrench.

Parameters

1. In the Model Builder, right-click Global Definitions and choose Parameters.

2. Go to the Parameters settings window. Under Parameters in the Parameters table (or under the table in the fields), enter these settings:
   - In the Name column or field, enter $F$.
   - In the Expression column or field, enter $150[N]$. The square-bracket notation is used to associate a physical unit to a numerical value, in this case the unit of force in Newton. The Value column is automatically updated based on the expression entered (when you leave the window or press Return).
   - In the Description column or field, enter Applied force.

The sections “Global Definitions” on page 45 and “Parameters, Functions, Variables and Model Couplings” on page 69 show you more about working with parameters.
So far you have added the physics and study, imported a geometry, added the material, and defined one parameter. The Model Builder node sequence should now match the figure to the right. The default feature nodes under Solid Mechanics are indicated by a ‘D’ in the upper left corner of the node icon.

The default nodes for Solid Mechanics are: a Linear Elastic Material model, a Free boundary condition that allows all boundaries to move freely with no constraint or load, and Initial Values for specifying initial displacement and velocity values for a nonlinear or transient analysis (not applicable in this case).

At any time you can save your model to be able to load it at a later time in exactly the state in which it was saved.

3 From the main menu, select File > Save As, browse to a folder where you have write permissions, and save the file as wrench.mph.
Domain Physics and Boundary Conditions

With the geometry and materials defined, you are now ready to set the boundary conditions.

1. In the Model Builder, right-click Solid Mechanics (solid) and select Fixed Constraint. This boundary condition constrains the displacement of each point on a boundary surface to be zero in all directions.

2. In the Graphics window, rotate the geometry by left-clicking and dragging into the position shown. Then left-click the cut-face of the partially modeled bolt (which turns the boundary red) and then right-click to select it (which turns the boundary blue). The Boundary number in the Selection list should be 35.

3. Click the Go to Default 3D View button on the Graphics toolbar to restore the geometry to the default view.
4 In the Model Builder, right-click Solid Mechanics (solid) and select Boundary Load. A Boundary Load node is added to the Model Builder sequence.

5 In the Graphics window, click the Zoom Box button on the toolbar and drag the mouse to highlight the area shown in the figure to the right. Release the mouse button.

6 Select the top socket face (Boundary 111) by left-clicking to highlight the boundary in red and then right-clicking it to highlight it in blue and add it to the Selection list.

7 In the Boundary Load settings window, under Force, select Total force as the Load type and enter -F in the text field for the z component. The negative sign
indicates the negative $z$ direction (downward). With these settings, the load of 150 N will be distributed uniformly across the selected surface.

Note that to simplify the modeling process, the mechanical contact between the bolt and the wrench is approximated with a material interface boundary condition. Such an internal boundary condition is automatically defined by COMSOL and guarantees continuity in normal stress and displacement across a material interface.

Mesh

The mesh settings determine the resolution of the finite element mesh used to discretize the model. The finite element method divides the model into small elements of geometrically simple shapes, in this case tetrahedrons. In each tetrahedron, a set of polynomial functions is used to approximate the structural displacement field—how much the object deforms in each of the three coordinate directions.

In this example, because the geometry contains small edges and faces, you will define a slightly finer mesh than the default setting suggests. This will better resolve the variations of the stress field and give a more accurate result. A finer mesh, however, comes at a cost: the computation time as well as memory usage will go up. Choosing a mesh size is always a trade-off between accuracy on one hand and speed and memory usage on the other.

1. In the Model Builder, under Model 1 click Mesh 1. In the Mesh settings window, under Mesh Settings, select Fine from the Element size list.

2. Click the Build All button on the Mesh settings window toolbar.
After a few seconds the mesh is displayed in the Graphics window. Zoom in to the mesh and have a look at the element size distribution.
In the beginning of setting up the model you selected a Stationary study, which implies that COMSOL will use a stationary solver. For this to be applicable, the assumption is that the load, deformation, and stress do not vary in time. The default solver settings will be good for this simulation if your computer has more than 2 GB of in-core memory (RAM). If you should run out of memory, the instructions below will show solver settings that make the solver run a bit slower but use up less memory. To start the solver:

1. Right-click Study 1 and select Compute (or press F8).

If your computer’s memory is below 2 GB you may at this point get an error message “Out of Memory During LU Factorization”. LU factorization is one of the numerical methods used by COMSOL for solving the large sparse matrix equation system generated by the finite element method.

You can easily solve this example model on a memory-limited machine by allowing the solver to use the hard drive instead of performing all of the computation using RAM. The steps below show how to do this. If your computer has more than 2 GB of RAM you can skip to the end of this section after step 5 below.

1. If you did not already start the computation, you can get access to the solver settings from the Study node. In the Model Builder, right-click Study 1 and choose Show Default Solver.
2 Under Study 1, expand the Solver Configurations node.
3 Expand the Stationary Solver 1 node and left-click Direct.
   A Direct solver is a fast and very robust type of solver that requires little or no manual tuning in order to solve a wide range of physics problems. The drawback is that it may require large amounts of RAM.
4 In the Direct settings window, in the General section, select the Out-of-core check box. Leave the default In-core memory (RAM) setting of 512 MB. This setting ensures that if your computer runs low of RAM during computation, the solver will start using the hard drive as a complement to RAM. Allowing the solver to use the hard drive instead of just RAM will slow the computation down somewhat.
5 Right-click Study 1 and select Compute (or press F8).
   After a few seconds of computation time, the default plot is displayed in the Graphics window. You can find other useful information about the computation in the Messages and Log windows; click the Messages and Log tabs under the Graphics window to see the kind of information available to you. These windows can also be opened from the main View menu.
Displaying Results

The von Mises stress is displayed in the Graphics window in a default Surface plot with the displacement visualized using a Deformation subnode. Change the default unit (N/m²) to the more suitable MPa as shown by following steps.

1. In the Model Builder, expand the Results>Stress (solid) node, then click Surface 1.

2. In the settings window under Expression, from the Unit list select MPa (or enter MPa in the field).

If you wish to study the stress more accurately, expand the Quality section. From the Recover list select Within domains. This setting will recover information about the stress level from a collection of elements rather than from each element individually. It is not active by default since it makes visualizations slower. The Within domain setting will treat each domain separately and the stress recovery will not cross material interfaces.
Click the Plot button in the toolbar of the settings window for the Surface plot and then the Zoom Extents button on the Graphics toolbar.

The plot is regenerated with the updated unit and shows the von Mises stress distribution in the bolt and wrench under an applied vertical load. (This plot does not use the Recover option described earlier.)

For a typical steel used for tools like a wrench, the yield stress is about 600 MPa, which means that we are getting close to plastic deformation for our 150 N load (which corresponds to about 34 pounds force). You may also be interested in a safety margin of, say, a factor of three. To quickly assess which parts of the wrench are at risk of plastic deformation, you can plot an inequality expression such as $\text{solid.mises} > 200\text{[MPa]}$.

1. Right-click the Results node and add a 3D Plot Group.
2. Right-click the 3D Plot Group 2 node and select Surface.
In the Surface settings window click the Replace Expression button and select Solid Mechanics>Stress>von Mises Stress (solid.mises). When you know the variable name beforehand, you can also directly enter solid.mises in the Expression field. Now edit this expression to: solid.mises>200[MPa].

This is a boolean expression that evaluates to either 1, for true, or 0, for false. In areas where the expression evaluates to 1, the safety margin is exceeded. (You also here use the Recover feature described earlier.)

Click the Plot button.

In the Model Builder, click 3D Plot Group 2. Press F2 and in the Rename 3D Plot Group dialog box, enter Safety Margin. Click OK.

The resulting plot shows that the stress in the bolt is high, but the focus of this exercise is on the wrench. If you wished to comfortably certify the wrench for a 150 N load with a factor-of-three safety margin, you would need to change the handle design somewhat, such as making it wider.

You may have noticed that the manufacturer, for various reasons, has chosen an asymmetric design of the wrench. Because of that, the stress field may be different if the wrench is flipped around. Try now, on your own, to apply the same force in the other direction and visualize the maximum von Mises stress to see if there is any difference.
**Convergence Analysis**

To check the accuracy of the computed maximum von Mises stress in the wrench, you can now continue with a mesh convergence analysis. Do that by using a finer mesh and thereby a higher number of degrees of freedom (DOFs).

This section illustrates some more in-depth functionality and the steps below could be skipped at a first reading. In order to run the convergence analysis below, a computer with at least 4GB of memory (RAM) is recommended. The numerical results shown in this section may vary slightly depending on the version of COMSOL that you use.

**Evaluating the Maximum von Mises Stress**

1. To study the maximum von Mises stress in the wrench, in the Results section of the Model Tree, right-click the Derived Values node and select Maximum>Volume Maximum.

2. In the Volume Maximum settings window under Selection choose Manual and select the wrench domain 1 by left-clicking on the wrench in the Graphics window and then right-clicking. We will only consider values in the wrench domain and neglect those in the bolt.

3. In the Expression text field enter the function \( ppr(solid.mises) \). The function \( ppr() \) corresponds to the Recover setting in the earlier note on page 34 for Surface plots. The Recover setting with the \( ppr \) function is used to increase the quality of the stress field results. It uses a polynomial-preserving recovery (ppr) algorithm, which is a higher-order interpolation of the solution on a patch of mesh elements around each mesh vertex. It is not active by default since it makes Results evaluations slower.

4. Under Expression, select or enter MPa as the Unit.

5. In the toolbar for Volume Maximum, click Evaluate to evaluate the maximum stress. The result will be displayed in a Table window and will be approximately 363 MPa.

   To see where the maximum value is attained, you can use a Max/Min Volume plot.

6. Right-click the Results node \( \square \) and add a 3D Plot Group \( \square \).

7. Right-click the 3D Plot Group 3 node \( \square \) and select More Plots>Max/Min Volume \( \square \).
In the Max/Min Volume settings window, in the Expression text field, enter the function \( ppr(\text{solid.mises}) \).

In the settings window under Expression, from the Unit list select MPa (or enter MPa in the field).

Click the Plot button . This type of plot simultaneously shows the location of the max and min values and also their coordinate location in the table below.

---

**PARAMETERIZING THE MESH**

We will now define a parametric sweep for successively refining the mesh size while solving and then finally plot the maximum von Mises stress vs. mesh size. First, let's define the parameters that will be used for controlling the mesh density.

1. In the Model Builder, click Parameters under Global Definitions.
2. Go to the Parameters settings window. Under Parameters in the Parameters table (or under the table in the fields), enter these settings:
   - In the Name column or field, enter \( \text{hd} \). This parameter will be used in the parametric sweep to control the element size.
   - In the Expression column or field, enter 1.
3. In the Description column or field, enter Element size divider.
Now, enter another parameter with Name \( h_0 \), Expression 0.01, and Description Starting element size. This parameter will be used to define the element size at the start of the parametric sweep.

In the Model Builder, under Model 1 click Mesh 1. In the Mesh settings window, under Mesh Settings, select User-controlled mesh from the Sequence type list.

Under Mesh 1, click the Size node.

In the Size settings window under Element Size, click the Custom button. Under Element Size Parameters, enter:
- \( h_0/h_d \) in the Maximum element size field.
- \( h_0/(4\times h_d) \) in the Minimum element size field.
- 1.3 in the Maximum element growth rate field.
- 0.1 in the Resolution of curvature field.
- 0.2 in the Resolution of narrow regions field.

See page 59 for more information on the Element Size Parameters.

**Parametric Sweep and Solver Settings**

As a next step, add a parametric sweep for the parameter \( h_d \).

1. In the Model Builder, right-click Study 1 and select Parametric Sweep. A Parametric Sweep node is added to the Model Builder sequence.
2. In the Parametric Sweep settings window, under the table, click the Add button. From the Parameter names list in the table, select \( h_d \).
Enter a range of Parameter values to sweep for. Click the Range button and enter the values in the Range dialog box. In the Start field, enter 1. In the Step field, enter 1, and in the Stop field, enter 6. Click Replace. The Parameter value list will now display range(1,1,6).

The settings above make sure that as the sweep progresses, the value of the parameter \(hd\) increases and the maximum and minimum element sizes decrease.

See page 96 for more information on defining parametric sweeps.

For the highest value of \(hd\), the number of DOFs will exceed one million. Therefore, we will switch to a more memory efficient iterative solver.

Under Study 1>Solver Configurations>Solver 1, expand the Stationary Solver 1 node, right-click Stationary Solver 1, and select Iterative. The Iterative solver option typically reduces memory usage but can require physics-specific tailoring of the solver settings for efficient computations.

Under General in the settings window for Iterative, set Preconditioning to Right. (This is an optional low-level solver option which in this case will avoid a warning message that otherwise will appear. However, this setting does not affect the resulting solution. Preconditioning is a mathematical transformation used to prepare the finite element equation system for using the Iterative solver.)

Right-click the Iterative 1 node and select Multigrid. The Multigrid iterative solver uses a hierarchy of meshes of different densities and different finite element shape function orders.

Click the Study 1 node and select Compute, either in the Settings window or by right-clicking the node. The computation time will be a few minutes (depending on the computer hardware) and memory usage will be about 4GB.

**RESULTS ANALYSIS**

As a final step, analyze the results from the parametric sweep by displaying the maximum von Mises stress in a Table.
In the Model Builder under Results>Derived values, select the Volume Maximum node.

The solutions from the parametric sweep are stored in a new Data set named Solution 2. Now change the Volume Maximum settings accordingly:

2. In the settings window for Volume Maximum, change the Data set to Solution 2.

3. From the Evaluate toolbar button at the top of the Volume Maximum settings window, select to evaluate in a New Table. This evaluation may take a minute or so.

4. To plot the results in the Table, click the Graph Plot button at the top of the Table window. Generating this plot may take a minute or so.

5. Right-click the Derived Values node and select Global Evaluation.

6. In the Expressions field, enter \texttt{numberofdofs}.

7. From the Evaluate toolbar button at the top of the Global Evaluation settings window, select to evaluate in a Table 2 (to display the DOF values for each parameter next to the previously evaluated data).

This convergence analysis shows that the computed value of the maximum von Mises stress in the wrench handle will increase from the original 367 MPa, for a mesh with about 50,000 DOFs, to 370 MPa for a mesh with about 1,100,000 DOFs. It also shows that 300,000 DOFs essentially gives the same accuracy as 1,100,000 DOFs; see the table below.

<table>
<thead>
<tr>
<th>DEGREES OF FREEDOM</th>
<th>COMPUTED MAX VON MISES STRESS (MPA)</th>
</tr>
</thead>
<tbody>
<tr>
<td>52,542</td>
<td>367.3</td>
</tr>
<tr>
<td>156,909</td>
<td>364.8</td>
</tr>
<tr>
<td>302,700</td>
<td>368.3</td>
</tr>
<tr>
<td>533,826</td>
<td>368.8</td>
</tr>
<tr>
<td>853,926</td>
<td>369.4</td>
</tr>
<tr>
<td>1,140,490</td>
<td>369.7</td>
</tr>
</tbody>
</table>

This concludes the wrench tutorial.
Example 2: The Busbar—A Multiphysics Model

Electrical Heating in a Busbar
This tutorial demonstrates the concept of multiphysics modeling in COMSOL. We will do this by introducing different phenomena sequentially. At the end, you will have built a truly multiphysics model.

The model that you are about to create analyzes a busbar designed to conduct direct current to an electric device (see picture below). The current conducted in the busbar, from bolt 1 to bolts 2a and 2b, produces heat due to the resistive losses, a phenomenon referred to as Joule heating. The busbar is made of copper while the bolts are made of a titanium alloy. The choice of materials is important because titanium has a lower electrical conductivity than copper and will be subjected to a higher current density.

The goal of your simulation is to precisely calculate how much the busbar heats up. Once you have captured the basic multiphysics phenomena, you will have the chance to investigate thermal expansion yielding structural stresses and strains in the busbar and the effects of cooling by an air stream.

The Joule heating effect is described by conservation laws for electric current and energy. Once solved for, the two conservation laws give the temperature and electric field, respectively. All surfaces, except the bolt contact surfaces, are cooled by natural convection in the air surrounding the busbar. You can assume that the exposed parts of the bolt do not contribute to cooling or heating of the device. The electric potential at the upper-right vertical bolt surface is 20 mV and the potential at the two horizontal surfaces of the lower bolts is 0 V.
Busbar Model Overview
More in-depth and advanced topics included with this tutorial are used to show you some of the many options available in COMSOL. The following topics are covered:

- “Parameters, Functions, Variables and Model Couplings” on page 69, where you learn how to define functions and model couplings.
- “Material Properties and Material Libraries” on page 73 shows you how to customize a material and add it to your own material library.
- “Adding Meshes” on page 75 gives you the opportunity to add and define two different meshes and compare them in the Graphics window.
- “Adding Physics” on page 77 explores the multiphysics capabilities by adding Solid Mechanics and Laminar Flow to the busbar model.
- “Parametric Sweeps” on page 96 shows you how to vary the width of the busbar using a parameter and then solve for a range of parameter values. The result is a plot of the average temperature as a function of the width.
- In the section “Parallel Computing” on page 104 you learn how to solve the model using Cluster Computing.

Model Wizard

Open the Model Wizard.

To open the Model Wizard, double-click the COMSOL icon on the desktop. Or when COMSOL is already open, choose between one of these three ways to open the Model Wizard:

- Click the New button on the main toolbar
- Select File > New from the main menu
- Right-click the root node and select Add Model
2 When the Model Wizard opens, select a space dimension; the default is 3D. Click the Next button.

3 In the Add Physics window, expand the Heat Transfer > Electromagnetic Heating folder, then right-click Joule Heating and choose Add Selected. Click the Next button. You can also double-click or click the Add Selected button to add physics.

Another way to open the Add Physics window is to right-click the Model node and select Add Physics.

Note that you may have fewer items in your physics list depending on the add-on modules installed. The figure on the right is shown for the case where all add-on modules are installed.
In the Select Study Type window, click to select the Stationary study type.

Click the Finish button.

Preset Studies are studies that have solver and equation settings adapted to the selected physics; in this example, Joule heating.

Any selection from the Custom Studies branch needs manual fine-tuning.

Note also here that you may have fewer study types in your study list depending on the installed add-on modules.

**Global Definitions**

To save time, it’s recommended that you load the geometry from a file. In that case, you can skip to “Geometry” on page 46.

If you, on the other hand, want to draw the geometry yourself, the Global Definitions branch is where you define the parameters. First complete the steps 1 to 3 below to define the parameter list for the model and then skip to the section “Appendix A—Building a Geometry” on page 107. You may then return to this section and use this busbar.mph file.

The Global Definitions node in the Model Builder stores Parameters, Variables, and Functions with a global scope. The Model Builder tree can hold several models simultaneously, and the Definitions with a global scope are made available for all models. In this particular example, there is only one Model node in which the parameters are used, so if you wish to limit the scope to this single model you
could define, for example, Variables and Functions in the Definitions subnode available directly under the corresponding Model node. However, no Parameters can be defined here because COMSOL Parameters are always global.

Since you will run a geometric parameter study later in this example, define the geometry using parameters from the start. In this step, enter parameters for the length for the lower part of the busbar, \( L \), the radius of the titanium bolts, \( \text{rad}_1 \), the thickness of the busbar, \( \text{tbb} \), and the width of the device, \( \text{wbb} \).

You will also add the parameters that control the mesh, \( \text{mh} \), a heat transfer coefficient for cooling by natural convection, \( \text{htc} \), and a value for the voltage across the busbar, \( \text{Vtot} \).

1. Right-click Global Definitions and choose Parameters. In the Parameters table, click the first row under Name and enter \( L \).
2. Click the first row under Expression and enter the value of \( L \), \( 9\,[\text{cm}] \). You can enter the unit inside the square brackets.
3. Continue adding the other parameters: \( \text{L}, \text{rad}_1, \text{tbb}, \text{wbb}, \text{mh}, \text{htc} \), and \( \text{Vtot} \) according to the Parameters list. It is a good idea to enter descriptions for variables in case you want to share the model with others and for your own future reference.

4. Click the Save button and name the model \( \text{busbar.mph} \). Then go to “Appendix A—Building a Geometry” on page 107.

**Geometry**

This section describes how the model geometry can be opened from the Model Library. The physics, study, parameters, and geometry are included with the model file you are about to open.
1 Select Model Library from the main View menu.

2 In the Model Library tree under COMSOL Multiphysics > Multiphysics, select busbar_geom.
   To open the model file you can:
   - Double-click the name
   - Right-click and select an option from the menu
   - Click one of the buttons under the tree
   The geometry in this model file is parameterized. In the next few steps, we will experiment with different values for the width parameter, \( w_{bb} \).
3 Under Global Definitions, click the Parameters node.
In the Parameters settings window, click in the \( w_{bb} \) parameter’s Expression column and enter \( 10 \text{[cm]} \) to change the value of the width \( w_{bb} \).

4 In the Model Builder, click the Form Union node and then the Build All button to rerun the geometry sequence.

5 In the Graphics toolbar click the Zoom Extents button to see the wider busbar in the Graphics window.
6 Experiment with the geometry in the Graphics window:
- To rotate the busbar, left-click and drag it.
- To move it, right-click and drag.
- To zoom in and out, center-click (and hold) and drag.
- To get back to the original position, click the Go to Default 3D View button on the toolbar.

7 Return to the Parameters table and change the value of \( w_{bb} \) back to 5 [cm].

8 In the Model Builder, click the Form Union node and then click the Build All button to rerun the geometry sequence.

9 On the Graphics toolbar, click the Zoom Extents button.

10 If you built the geometry yourself you are already using the \( \text{busbar.mph} \) file, but if you opened the Model Library file, from the main menu, select File > Save As and rename the model \( \text{busbar.mph} \).

After creating or opening the geometry file, it is time to define the materials.

**Materials**

The Materials node stores the material properties for all physics and geometrical domains in a Model node. The busbar is made of copper and the bolts are made of titanium. Both these materials are available from the Built-In material database.
In the Model Builder, right-click Materials and select Open Material Browser.

The Materials node will show a red × in the lower-right corner if you try to solve without first defining a material (you are about to define that in the next few steps).

In the Material Browser, expand the Built-In materials folder and locate Copper. Right-click Copper and select Add Material to Model.

A Copper node is added to the Model Builder.

Click the Material Browser tab.

In the Material Browser, scroll to Titanium beta-21S in the Built-In material folder list. Right-click and select Add Material to Model.
In the Model Builder, collapse the Geometry 1 node to get an overview of the model.

Under the Materials node, click Copper.

In the Material settings window, examine the Material Contents section.

The Material Contents section has useful feedback about the model’s material property usage. Properties that are both required by the physics and available from the material are marked with a green check mark. Properties required by the physics but missing in the material are marked with a warning sign. A property that is available but not used in the model is unmarked.

The Coefficient of thermal expansion in the table above is not used, but will be needed later when heat-induced stresses and strains are added to the model.
Because the copper material is added first, by default all parts have copper material assigned. In the next step you will assign titanium properties to the bolts, which overrides the copper material assignment for those parts.

8 In the Model Builder, click Titanium beta-21S.

9 Select All Domains from the selection list and then click Domain 1 in the list.
Now remove Domain 1 from the selection list.
To remove a domain from the selection list (or any geometric entity such as boundaries, edges, or points), you can use either of these two methods:
- Click Domain 1 in the selection list found in the Material settings window, then click the Remove from Selection button.
- In the Graphics window, click domain 1 to select it, and then right-click to remove it from the selection list.
In the Material settings window, be sure to inspect the Material Contents section for the titanium material. All the properties used by the physics should have a green check mark.

Close the Material Browser.
Next you will inspect the physics domain settings and set the boundary conditions for the heat transfer problem and the conduction of electric current.

In the Model Builder, expand the Joule Heating node to examine the default physics nodes. The ‘D’ in the upper left corner of a node’s icon means it is a default node.

The equations that COMSOL solves are displayed in the Equation section of the settings window.

The default equation form is inherited from the study added in the Model Wizard. For the Joule Heating node, COMSOL displays the equations solved for the temperature and electric potential.

To always display the section in its expanded view, click the Expand Sections button on the Model Builder toolbar and select Equations. Selecting this option expands all the Equation sections on physics settings windows.
The domain level Joule Heating Model 1 node has the settings for heat conduction and current conduction.

The contributions of the Joule Heating Model 1 node to the equation system are underlined in the Equation section.

The heating effect for Joule heating is set in the Electromagnetic Heat Source 1 node. The Electric Insulation 1 node corresponds to the conservation of electric current, and the Thermal Insulation 1 node contains the default boundary condition for the heat transfer problem.

The Initial Values 1 node contains initial guesses for the nonlinear solver for stationary problems and initial conditions for time-dependent problems.

2 Right-click the Joule Heating node . In the second section of the context menu—the boundary section—select Heat Transfer>Heat Flux.
3 In the Heat Flux settings window, select All boundaries from the Selection list. Assume that the circular bolt boundaries are neither heated nor cooled by the surroundings. In the next step you will remove the selection of these boundaries from the heat flux selection list, which leaves them with the default insulating boundary condition for the Heat Transfer interfaces.

4 Rotate the busbar to view the back. Click one of the circular titanium bolt surfaces to highlight it in green. Right-click anywhere in the Graphics window to remove this boundary selection from the Selection list. Repeat this step to remove the other two circular bolt surfaces from the selection list. Boundaries 8, 15, and 43 are removed.

Cross-check: Boundaries 8, 15, and 43 are removed from the Selection list.
In the Heat Flux settings window under Heat Flux, click the Inward heat flux button. Enter $h\cdot c$ in the Heat transfer coefficient field, $h$.

This parameter was either entered in the Parameter table in “Global Definitions” on page 45 or imported with the geometry.

Continue by setting the boundary conditions for the electric current according to the following steps:

In the Model Builder, right-click the Joule Heating node. In the second section of the context menu—the boundary section—select Electric Currents > Electric Potential. An Electric Potential node is added to the Model Builder.
7 Click the circular face of the upper titanium bolt to highlight it and right-click anywhere to add it (boundary 43) to the Selection list.

8 In the Electric Potential settings window, enter \( V_{\text{tot}} \) in the Electric potential field.
   The last step is to set surfaces of the two remaining bolts to ground.

9 In the Model Builder, right-click the Joule Heating node. In the boundary section of the context menu, select Electric Currents > Ground. A Ground node is added to the Model Builder.
   The node sequence under Joule Heating should now match this figure.
10 In the Graphics window, click one of the remaining bolts to highlight it. Right-click anywhere to add it to the Selection list. Repeat this step to add the last bolt. Boundaries 8 and 15 are added to the selection list for the Ground boundary condition.

11 On the Graphics toolbar, click the Go to Default 3D View button.

Mesh

The simplest way to mesh is to create an unstructured tetrahedral mesh, which is perfect for the busbar. Alternatively, you can create several meshing sequences as shown in “Adding Meshes” on page 75.

A physics-controlled mesh is created by default. In most cases, it is possible to skip to the Study branch and just solve the model. For this exercise, the settings are investigated in order to parameterize the mesh settings.
In the Model Builder, click the Mesh 1 node. In the Mesh settings window, select User-controlled mesh from the Sequence type list.

Under Mesh 1, click the Size node. The asterisk (*) that displays in the upper-right corner of the icon indicates that the node is being edited.

In the Size settings window under Element Size, click the Custom button.

Under Element Size Parameters, enter:

- \( mh \) in the Maximum element size field. Notice that \( mh \) is 6 mm—the value entered earlier as a global parameter. By using the parameter \( mh \), element sizes are limited to this value.
- \( mh - mh/3 \) in the Minimum element size field. The Minimum element size is slightly smaller than the maximum size.
- 0.2 in the Resolution of curvature field.

The Resolution of curvature determines the number of elements on curved boundaries: a lower value gives a finer mesh.

The Maximum element growth rate determines how fast the elements should grow from small to large over a domain. The larger this value is, the larger the growth rate. A value of 1 does not give any growth.

The Resolution of narrow regions works in a manner similar to the Resolution of curvature.
4 Click the Build All button  in the Size settings window to create the mesh as in this figure:

Study

1 To run a simulation, in the Model Builder, right-click Study 1 and choose Compute . Or press F8. The Study node automatically defines a solution sequence for the simulation based on the selected physics and the study type. The simulation only takes a few seconds to solve.
Results

The default plot displays the temperature in the busbar. The temperature difference in the device is less than 10 K due to the high thermal conductivity of copper and titanium. The temperature variations are largest on the top bolt, which conducts double the amount of current compared to the two lower bolts. The temperature is substantially higher than the ambient temperature of 293 K.

1 Click and drag the image in the Graphics window to rotate and view the back of the busbar.

2 On the Graphics toolbar, click the Go to Default 3D View button .

You can now manually set the color table range to visualize the temperature difference in the copper part.

3 In the Model Builder, expand the Results > Temperature node and click the Surface 1 node .
4 In the Surface settings window, click Range to expand the section. Select the Manual color range check box and enter 323 in the Maximum field (replace the default).
5 Click the Plot button on the Surface settings window. On the Graphics toolbar, click the Zoom Extents button to view the updated plot.

![Temperature Distribution Plot](image1)

6 Click and drag in the Graphics window to rotate the busbar and view the back.

![Temperature Distribution Plot](image2)

The temperature distribution is laterally symmetric with a vertical mirror plane running between the two lower titanium bolts and cutting through the center of the upper bolt. In this case, the model does not require much computing power and you can model the whole geometry. For more complex models, you can consider using symmetries to reduce the computational requirements.

Now let us generate a Surface plot that shows the current density in the device.
1 In the Model Builder, right-click Results and add a 3D Plot Group. Right-click 3D Plot Group 2 and add a Surface node.

2 In the Surface settings window under Expression, click the Replace Expression button. Select Joule Heating (Electric Currents) > Currents and charge > Current density norm (jh.normJ).

jh.normJ is the variable for the magnitude, or absolute value, of the current density vector. You can also enter jh.normJ in the Expression field when you know the variable name.

3 Click the Plot button.

The plot that displays in the Graphics window is almost uniform in color due to the high current density at the contact edges with the bolts. The next step is to manually change the color table range to visualize the current density distribution.

4 On the Surface settings window under Range, select the Manual color range check box. Enter 1e6 in the Maximum field and replace the default.
Click the Plot button. The plot automatically updates in the Graphics window.

The resulting plot shows how the current takes the shortest path in the 90-degree bend in the busbar. Notice that the edges of the busbar outside of the bolts are hardly utilized for current conduction.
6 Click and drag the busbar in the Graphics window to view the back. Continue rotating the image to see the high current density around the contact surfaces of each of the bolts.

![Surface: Current density norm (A/m²)](image)

Make sure to save the model. This version of the model, `busbar.mph`, is reused and renamed during the next set of tutorials. When you are done, click the Go to Default 3D View button on the Graphics toolbar and create a model thumbnail image.

**CREATING MODEL IMAGES FROM PLOTS**

With any solution, you can create an image to display in COMSOL when browsing for model files. After generating a plot, select File>Save Model Thumbnail from the main menu.

There are two other ways to create images from a plot. One is to click the Image Snapshot button in the Graphics toolbar to directly create an image. You can also add an Image node to an Export node, for creating image files, by right-clicking the plot group of interest and then selecting Add Image to Export.

This completes the Busbar example. The next sections are designed to improve your understanding of the steps implemented so far, and to extend your simulation to include additional effects like thermal expansion and fluid flow. These additional topics begin on the following pages:

- “Parameters, Functions, Variables and Model Couplings” on page 69
• “Material Properties and Material Libraries” on page 73
• “Adding Meshes” on page 75
• “Adding Physics” on page 77
• “Parametric Sweeps” on page 96
• “Parallel Computing” on page 104
• “Appendix A—Building a Geometry” on page 107
Advanced Topics

Parameters, Functions, Variables and Model Couplings

This section explores working with Parameters, Functions, Variables and Model Couplings.

Global Definitions and Model Definitions contain functionality that help you to prepare model inputs and model couplings and to organize simulations. You have already used the functionality for adding Parameters to organize model inputs in “Global Definitions” on page 45.

Functions, available as both Global Definitions and Model Definitions, contain a set of predefined functions templates that can be useful when setting up multiphysics simulations. For example, the Step function template can create a smooth step function for defining different types of spatial or temporal transitions.

To illustrate using functions, assume that you want to add a time dependent study to the busbar model by applying an electric potential across the busbar that goes from 0 V to 20 mV in 0.5 seconds. For this purpose, you could use a step function to be multiplied with the parameter \( V_{tot} \). Add a function that goes smoothly from 0 to 1 in 0.5 seconds to find out how functions can be defined and verified.

Defining Functions

For this section, you can continue working with the same model file created in the previous section. Locate and open the file busbar.mph if it is not already open on the COMSOL Desktop.
1 Right-click the Global Definitions node and select Functions > Step.

2 In the Step settings window, enter 0.25 in the Location field to set the location of the middle of the step, where it has the value of 0.5.

3 Click Smoothing to expand the section and enter 0.5 in Size of the transition zone field to set the width of the smoothing interval. Keep the default Number of continuous derivatives at 2.

4 Click the Plot button in the Step settings window.
If your plot matches the one below, this confirms that you have defined the function correctly.

You can also add comments and rename the function to make it more descriptive.

5 Right-click the Step 1 node in the Model Builder and select Properties.

6 In the Properties window, enter any information you want.
For the purpose of this exercise, assume that you want to introduce a second model to represent an electric device connected to the busbar through the titanium bolts.

A first step would be to rename Model 1 to specify that it represents the busbar.

1. Right-click the Model 1 node and select Rename (or press F2).
2. In the Rename Model window, enter Busbar. Click OK and save the model.

**DEFINING MODEL COUPLINGS**

Click the Definitions node under Busbar (mod1) to introduce a Model Coupling that computes the integral of any Busbar (mod1) variable at the bolt boundaries facing the electric device. You can use such a coupling, for example, to define a Variable in the Global Definitions that calculates the total current. This variable is then globally accessible and could, for example, form a boundary condition for the current that is fed to the electric device in the Electric Device (mod2) node.

The Model Couplings in Definitions have a wide range of use. The Average, Maximum, and Minimum model couplings have applications in generating results as well as in boundary conditions, sources, sinks, properties, or any other contribution to the model equations. The Probes are for monitoring the solution progress. For instance, you can follow the solution at a critical point during a time-dependent simulation, or for each parameter value in a parametric study.

You can find an example of using the average operator in “Parametric Sweeps” on page 96. Also see “Functions” on page 128, for a list of available COMSOL functions.
To learn more about working with definitions, in the Model Builder click the Definitions or Global Definitions node and press F1 to open the Help window. This window displays help about the selected item in the COMSOL Desktop and provides links to the documentation. It could take up to a minute for the window to load the first time it is activated, but the next time it will load quickly.

**Material Properties and Material Libraries**

Up to now, you have used the functionality in Materials to access the properties of copper and titanium in the busbar model. In Materials, you are also able to define your own materials and save them in your own material library. You can also add material properties to existing materials. In cases where you define properties that are functions of other variables, typically temperature, the plot functionality helps you to verify the property functions in the range of interest. You can also load Excel® spreadsheets and define interpolation functions for material properties using LiveLink™ for Excel®.

The Material Library add-on contains over 2500 materials with tens of thousands of temperature-dependent property functions.

In the near future, you will also be able to import material properties from CAD using the CAD LiveLink add-ons.

First investigate how to add properties to an existing material. Assume that you want to add bulk modulus and shear modulus to the copper properties.

**CUSTOMIZING MATERIALS**

Let us keep working on the busbar.

1. In the Model Builder, under Materials, click Copper.
In the Material settings window, the Materials Properties section contains a list of all the definable properties. Expand the Solid Mechanics > Linear Elastic Material section. Right-click Bulk Modulus and Shear Modulus and select Add to Material. This lets you define the bulk modulus and shear modulus for the copper in your model.

Locate the Material Contents section. Bulk modulus and Shear modulus rows are now available in the table. The warning sign indicates the values are not yet defined. To define the values, click the Value column. In the Bulk modulus row, enter 140e9 and in the Shear modulus row, enter 46e9.

By adding these material properties, you have changed the Copper material. You cannot save this in the read-only Solid Mechanics material library, however, you can save it to your own material library.

In the Model Builder, right-click Copper and select Add Material to “User Defined Library”.

2 In the Material settings window, the Materials Properties section contains a list of all the definable properties. Expand the Solid Mechanics > Linear Elastic Material section. Right-click Bulk Modulus and Shear Modulus and select Add to Material. This lets you define the bulk modulus and shear modulus for the copper in your model.

3 Locate the Material Contents section. Bulk modulus and Shear modulus rows are now available in the table. The warning sign indicates the values are not yet defined. To define the values, click the Value column. In the Bulk modulus row, enter 140e9 and in the Shear modulus row, enter 46e9.

By adding these material properties, you have changed the Copper material. You cannot save this in the read-only Solid Mechanics material library, however, you can save it to your own material library.

4 In the Model Builder, right-click Copper and select Add Material to “User Defined Library”.

Advanced Topics
Adding Meshes

A model can contain different meshing sequences to generate meshes with different settings. These sequences can then be accessed by the study steps. In the study, you can select which mesh you would like to use in a particular simulation. In the busbar model, a second mesh node is now added to create a mesh that is refined in the areas around the bolts and the bend.

Adding a Mesh

1. In order to keep this model in a separate file for later use, from the main menu, select File > Save as and rename the model busbar_I.mph.

2. To add a second mesh node, right-click the Busbar (mod1) node and select Mesh. By adding another Mesh node, it creates a Meshes parent node that contains both Mesh 1 and Mesh 2.

3. Click the Mesh 2 node. In the Mesh settings window under Mesh Settings, select User-controlled mesh as the Sequence type. A Size and Free Tetrahedral node are added under Mesh 2.
4 In the Model Builder, under Mesh 2, click Size.

The asterisk in the upper-right corner of a node icon indicates that the node is being edited.

5 In the Size settings window under Element Size, click the Custom button.

6 Under Element Size Parameters, enter:
   - \( mh/2 \) in the Maximum element size field, where \( mh \) is 6 mm—the mesh control parameter entered earlier
   - \( mh/2 - mh/6 \) in the Minimum element size field
   - 0.2 in the Resolution of curvature field.

7 Click the Build All button.
Compare Mesh 1 and Mesh 2 by clicking the Mesh nodes. The mesh is updated in the Graphics window. An alternative for using many different meshes is to run a parametric sweep of the parameter for the maximum mesh size, \( m_h \), that was defined in the section “Global Definitions” on page 45.

**Adding Physics**

COMSOL’s distinguishing characteristics of adaptability and compatibility are prominently displayed when you add physics to an existing model. In this section, you will understand the ease with which this seemingly difficult task is performed. By following these directions, you can add structural mechanics and fluid flow to the busbar model.

**Structural Mechanics**

After completing the busbar Joule heating simulation, we know that there is a temperature rise in the busbar. What kind of mechanical stress is induced by thermal expansion? To answer this question, let us expand the model to include the physics associated with structural mechanics.
To complete these steps, either the Structural Mechanics Module or the MEMS Module (which enhances the standard Solid Mechanics interface) is required.

If you want to add cooling by fluid flow, or don’t have the Structural Mechanics Module or MEMS Module, read this section and then go to “Cool by Adding Fluid Flow” on page 83.

1. Open the model `busbar.mph` that was created earlier. From the main menu, select File>Save as and rename the model `busbar_II.mph`.

2. In the Model Builder, right-click the Busbar node and select Add Physics.

3. In the Model Wizard under Structural Mechanics, select Solid Mechanics. To add this interface, you can double-click it, right-click and select Add Selected, or click the Add Selected button.

4. Click the Finish button and save the file. You do not need to add any studies.

When adding additional physics, you need to make sure that materials included in the Materials node have all the required properties for the selected physics. In this example, you already know that all properties are available for copper and titanium.

You can start by adding the effect of thermal expansion to the structural analysis.
5 In the Model Builder under Solid Mechanics, right-click the Linear Elastic Material 1 node and from the domain level select Thermal Expansion. A Thermal Expansion node is added to the Model Builder.

6 In the Thermal Expansion settings window under Model Inputs, select Temperature (jh/jhm1) from the Temperature list. This is the temperature field from the Joule Heating interface (jh/jhm1) and couples the Joule heating effect to the thermal expansion of the busbar.

With the Structural Mechanics Module, the Thermal Stress predefined multiphysics interface is also available to define thermal stresses and strains.

Next, constrain the busbar at the position of the titanium bolts.

7 In the Model Builder, right-click Solid Mechanics and from the boundary level, select Fixed Constraint. A node with the same name is added to the Model Builder.

8 Click the Fixed Constraint node. In the Graphics window, rotate the busbar to view the back. Click the circular surface of one of the bolts to highlight it and right-click to add this surface to the Selection list.
Repeat this procedure for the remaining bolts to add boundaries 8, 15, and 43.

Next we update the Study to take the added effects into account.

**SOLVING FOR JOULE HEATING AND THERMAL EXPANSION**

The Joule heating effect is independent of the stresses and strains in the busbar, assuming small deformations and ignoring the effects of electric contact pressure. This means that you can run the simulation using the temperature as input to the structural analysis. In other words, the extended multiphysics problem is weakly coupled. As such, you can solve it in two separate study steps to save computation time—one for Joule heating and a second one for structural analysis.

1. In the Model Builder, right-click Study 1 and select Study Steps>Stationary to add a second stationary study step.

When adding study steps you need to manually connect the correct physics with the correct study step. We shall start by removing the structural analysis from the first step.

2. Under Study 1, click the Step 1: Stationary node.
3 In the Stationary settings window, locate the Physics and Variables Selection.

4 In the Solid Mechanics (solid) row under Solve for, click to change the check mark ✓ to an ✗ to remove Solid Mechanics from Study 1.

Now repeat these steps to remove Joule heating from the second study step.

5 Under Study 1, click Step 2: Stationary 2.

6 Under Physics and Variables Selection, in the Joule Heating (jh) row under Solve for, click to change the check mark ✓ to an ✗ to remove Joule Heating from Step 2.

7 Right-click the Study 1 node and select Compute (or press F8) to solve the problem.

Save the file busbar_II.mph, which now includes the Solid Mechanics interface and the additional study step.

**RESULTING DEFORMATION**

Now add a displacement to the plot.
1. Under Results>3D Plot Group 2, click the Surface 1 node.

2. In the Surface settings window in the Expression section, click the Replace Expression button. From the context menu, select Solid Mechanics>Displacement>Total Displacement. You can also enter `solid.disp` in the Expression field.

3. Click Range to expand the section. Click to clear the Manual color range check box.

The local displacement due to thermal expansion is displayed by COMSOL as a surface plot. Next we'll add information about the busbar deformation.

4. In the Model Builder, under Results>3D Plot Group 2, right-click the Surface 1 node and add a Deformation. The plot automatically updates in the Graphics window.
The deformations shown in the figure are highly amplified to make visible the very small distortions that actually take place.

5 Save the busbar_II.mph file, which now includes a Surface plot with a Deformation.

You can also plot the von Mises and principal stresses to assess the structural integrity of the busbar and the bolts.

Cool by Adding Fluid Flow

After analyzing the heat generated in the busbar and possibly the induced thermal stresses, you might want to investigate ways of cooling it by letting air flow over its surfaces. These steps do not require any additional modules.

When you have the CFD Module or the Heat Transfer Module, the Conjugate Heat Transfer multiphysics interface is available. This automatically defines coupled heat transfer in solids and fluids including laminar or turbulent flow.

Adding fluid flow to the Joule heating model forms a new multiphysics coupling. To simulate the flow domain, you need to create an air box around the busbar. You can do this manually by altering the geometry from your first model or by opening a Model Library file. In this case, you will open a model with the box already created.
Having loaded the geometry, you will now learn how to simulate air flow according to this figure:

**Defining Inlet Velocity**

Start by loading the geometry and adding a new parameter for the inlet flow velocity.

1. Select View>Model Library and navigate to COMSOL Multiphysics>Multiphysics>busbar_box. Double-click to open the model file, which contains the geometry in addition to the physics modeling steps completed up to the end of the section “Customizing Materials” on page 73.
2 Under Global Definitions, click the Parameters node.

3 In the Parameters settings window, click the empty row just below the \( V_{tot} \) row. In the Name column, enter \( V_{in} \). Enter \( 1 \times 10^{-1} \text{[m/s]} \) in the Expression column and a description of your choice in the Description column.

4 Select File>Save As and save the model with a new name, busbar_box_I.mph.

**Adding Air**

The next step is to add the material properties of air.

1 Select View>Material Browser.

2 In the Material Browser, expand the Built-In tree. Right-click Air and select Add Material to Model. Click the Material Browser tab and close it.

3 In the Model Builder under Materials, click the Air node.

---

Advanced Topics | 85
4 In the Graphics window, click the air box (Domain 1) to highlight it (in red) and right-click to add it to the Selection list (which changes the color to blue).

**ADDING FLUID FLOW**

Now add the physics of fluid flow.

1. In the Model Builder, right-click Model 1 and select Add Physics.

2. In the Add Physics tree under Fluid Flow>Single-Phase Flow double-click Laminar Flow to add it to the Selected physics section. You do not need to add any more studies. Click the Finish button.
3 On the Graphics toolbar, click the Select Boundaries button and then the Wireframe rendering button to look inside the box.

Now that you have added fluid flow to the model, you need to couple the heat transfer part of the Joule Heating interface to the fluid flow.

4 In the Model Builder, right-click Joule Heating. In the first section of the context menu, the domain level, select Heat Transfer>Heat Transfer in Fluids.
5 In the Graphics window select the air box (Domain 1) and right-click to add it to the Selection list. Now couple the fluid flow and the heat transfer phenomena.

6 In the Heat Transfer in Fluids settings window under Model Inputs, select Velocity field (spf/fp1) from the Velocity field list. This identifies the flow field from the Laminar Flow interface and couples it to heat transfer. Now define the boundary conditions by specifying the inlet and outlet for the heat transfer in the fluid domain.

7 In the Model Builder, right-click Joule Heating. In the second section of the context menu, the boundary section, select Heat Transfer>Temperature. A Temperature node is added to the Model Builder.
8 In the Graphics window, click the inlet boundary, Boundary 2, and right-click to add it to the Selection list. This sets the inlet temperature to 293.15 K, the default setting. Click the Transparency button in the Graphics toolbar to turn off transparency, since we do not need this anymore. Click the Wireframe Rendering button in the Graphics toolbar. The graphics should look like the image on the right. Continue by defining the outlet.

9 In the Model Builder, right-click Joule Heating. At the boundary level, select Heat Transfer>Outflow. An Outflow node is added to the Model Builder.
In the Graphics window, click the outlet boundary, Boundary 5, and right-click to add it to the Selection list.

The settings for the busbar, the bolts and the Electric Potential 1 and Ground 1 boundaries have retained the correct selection, even though you added the box geometry for the air domain. To confirm this, click the Electric Potential 1 and the Ground 1 nodes in the Model Builder to verify that they have the correct boundary selection.

Let’s continue with the flow settings. You need to indicate that fluid flow only takes place in the fluid domain and then set the inlet, outlet, and symmetry conditions.
1. In the Model Builder, click the Laminar Flow node. In the Laminar Flow settings window, click the Clear Selection button.

![Laminar Flow node in Model Builder]

2. In the Graphics window, click the air box (Domain 1) and right-click to add it to the Selection.

   It is good practice to verify that the Air material under the Materials node has all the properties that this multiphysics combination requires. In the Model Builder under Materials, click Air. In the Material settings window under Material Contents, verify that there are no missing properties, which are marked with a warning sign. The section “Materials” on page 49 has more information.

   Let’s continue with the boundaries.

3. In the Model Builder, right-click Laminar Flow and at the boundary level select Inlet. An Inlet node is added to the Model Builder.

![Inlet node added to Model Builder]
4 In the Graphics window, select the inlet (Boundary 2) and right-click to add it to the Selection list.

5 In the Inlet settings window under Velocity in the $U_0$ field, enter $V_{in}$ to set the Normal inflow velocity.

6 Right-click Laminar Flow and at the boundary level select Outlet. In the Graphics window, select the outlet (Boundary 5) and right-click to add it to the Selection list.

   The last step is to add symmetry boundaries. You can assume that the flow just outside of the faces of the channel is similar to the flow just inside these faces. This is correctly expressed by the symmetry condition.

7 Right-click Laminar Flow and select Symmetry. A Symmetry node is added to the sequence.
In the Graphics window, click one of the blue faces in the figure below (Boundaries 1, 3, 4, or 48) and right-click each one to add all to the Selection list.

Save the `busbar_box_1.mph` file, which now includes the Air material and Laminar Flow interface settings.

When you know the boundaries, you can click the Paste button and enter the information. In this example, enter 1, 3, 4, 48 in the Paste selection window. Click OK and the boundaries are automatically added to the Selection list.

**Coarsening the Mesh**

To get a quick solution, we will change the mesh slightly and make it coarser. The current mesh settings would take a relatively long time to solve, and you can always refine it later.

1. In the Model Builder, expand the Mesh 1 node and click the Size node.

2. In the Size settings window under Element Size, click the Predefined button and ensure that Normal is selected.
3 Click the Build All button. The geometry displays with a coarse mesh in the Graphics window.

You can assume that the flow velocity is large enough to neglect the influence of the temperature increase in the flow field.

It follows that you can solve for the flow field first and then solve for the temperature using the results from the flow field as input. This is implemented with a study sequence.

**SOLVING FOR FLUID FLOW AND JOULE HEATING**

When the flow field is solved before the temperature field it yields a weakly coupled multiphysics problem. The study sequence described in this section automatically solves such a weak coupling.

1 In the Model Builder, right-click Study 1 and select Study Steps>Stationary to add a second stationary study step to the Model Builder.

Next, the correct physics needs to be connected with the correct study step. Start by removing Joule heating from the first step.
2 Under Study 1, click Step 1: Stationary.

3 In the Stationary settings window locate the Physics and Variables Selection section. In the Joule Heating (jh) row, click to change the check mark to an in the Solve for column, removing Joule Heating (jh) from Study 1.

4 Repeat the step. Under Study 1 click Step 2: Stationary 1. Under Physics and Variables Selection, in the Laminar Flow (spf) row click in the Solve for column to change the check mark to an .

5 Right-click the Study 1 node and select Compute (or press F8) to automatically create a new solver sequence that solves the two problems in sequence.
After the solution is complete, click the Transparency button on the Graphics toolbar to visualize the temperature field inside the box.

The Temperature Surface plot that displays in the Graphics window shows the temperature in the busbar and in the surrounding box. You can also see that the temperature field is not smooth due to the relatively coarse mesh. A good strategy to get a smoother solution would be to refine the mesh to estimate the accuracy.

Save the busbar_box_I.mph file up to this point so you can return to this file if you want. The next steps use the original busbar.mph file.

**Parametric Sweeps**

**Sweeping a Geometric Parameter**

It is often useful to generate multiple instances of a design with the objective of meeting specific constraints. In the previous busbar example, a design goal might be to lower the operating temperature, or to decrease the current density. We will demonstrate the former. Since the current density depends on the geometry of the busbar, varying the width, \( w_{bb} \), should change the current density and, in turn,
have some impact on the operating temperature. Let us run a parametric sweep on \( wbb \) to study this change.

**A D D I N G  A  P A R A M E T R I C  S W E E P**

1. Open the model file `busbar.mph`. In the Model Builder, right-click Study 1 and select Parametric Sweep. A Parametric Sweep node is added to the Model Builder sequence.

2. In the Parametric Sweep settings window, under the table, click the Add button. From the Parameter names list in the table, select \( wbb \).

   ![Parametric Sweep settings window](image)

   *The Sweep type, available above the Parameter names, is used to control parametric sweeps with multiple parameters. You select between sweeping for All combinations of the given parameters or a subset of Specified combinations.*
3 Enter a range of Parameter values to sweep the width of the busbar from 5 cm to 10 cm with 1 cm increments. There are different ways to enter this information:

- Copy and paste or enter `range(0.05, 0.01, 0.1)` into the Parameter value list field.

- Click the Range button and enter the values in the Range dialog box. In the Start field, enter `5e-2`. In the Step field, enter `1e-2`, and in the Stop field, enter `1e-1`. Click Replace.

Next, define an Average Model Coupling, which can later be used to calculate the average temperature in the busbar.

4 Under Model 1, right-click Definitions and select Model Couplings>Average.

5 In the Average settings window select All domains from the Selection list. This creates an operator called `aveop1`.

The `aveop1` is now available to calculate the average of any quantity defined on those domains. A little later this is used to calculate the average temperature, but it can also be used to calculate average electric potential, current density, and so forth.

6 Right-click Study 1 and select Compute to run the sweep.

7 Select File>Save As to save the model with a new name, `busbar_III.mph`. 
PARAMETRIC SWEEP RESULTS

A Temperature (jh) 1 node is added under Results. The plot that displays in the Graphics window after the parametric sweep shows the temperature in the wider busbar using the last parameter value, \( wbb = 0.1 \text{ [m]} \) \( (10 \text{ [cm]}) \). The plot is rather uniform in color, so we need to change the maximum color range.

1. Under the Temperature (jh) 1 node, click the Surface node.

2. In the Surface settings window, click Range to expand the section. Select the Manual color range check box. Enter 309.35 in the Maximum field (replace the default) to plot \( wbb \) at 10 cm.
3 The Temperature ($j_h$) plot is updated in the Graphics window for $w_{bb}=0.1\text{[m]}$ ($10\text{[cm]}$).

![Temperature Plot](image)

Compare the wider busbar plot to the temperature for $w_{bb}=0.05\text{[m]}$ ($5\text{[cm]}$).

1 In the Model Builder, click the first Temperature ($j_h$) node.

2 In the 3D Plot Group settings window, select Solution 2 from the Data set list. This data set contains the results from the parametric sweep.

3 In the Parameters value list, select 0.05 (which represents $w_{bb}=0.05\text{[m]}$). Click the Plot button. Click the Zoom Extents button on the Graphics toolbar.
The Temperature (jh) plot is updated for $w_{bb}=0.05\,[m]$ (5\,[cm]) . Note that you may have updated the color range for this plot already and then your plot may look different compared to the one below. If not, follow the steps below.

Like the wider busbar, the plot may be quite uniform in color, so change the maximum color range.

1. Under the first Temperature (jh) node, click the Surface node.
2. In the Surface settings window, click Range to expand the section (if it is not already expanded). Select the Manual color range check box.
Enter 323 in the Maximum field (replace the default) to plot \( w_{bb} \) at 5 cm. The Temperature (\( jh \)) plot is updated in the Graphics window for \( w_{bb}=0.05 \text{[m]} \) (5 cm).

Click the first and second Temperature plot nodes to compare the plots in the Graphics window. The plots show that the maximum temperature decreases from 331 K to 318 K as the width of the busbar increases from 5 cm to 10 cm.

**Adding More Plots**

To further analyze these results, you can plot the average temperature for each width.

1. Right-click Results and add a 1D Plot Group.
2. In the 1D Plot Group settings window, select Solution 2 from the Data set list.
3 In the Model Builder, right-click 1D Plot Group 4 and add a Global node.

4 Under y-Axis Data, click the first row in the Expressions column and enter \( \text{aveop1}(T) \). This operator is the one we defined on page 98 for later use. You use a similar syntax to calculate the average of other quantities.

5 Click to expand the Legends section. Select the Expression check box. This adds a legend at the top right corner of the graph.
6 Click the Plot button and save the *busbar_III.mph* model with these additional plots that use the parametric sweep results.

In the plot, the average temperature also decreases as the width increases. This indicates that the goal of a lower operating temperature would be fulfilled by using a wider busbar.

The subject of parametric sweeps raises the question of parallel computing; it would be efficient if all parameters were solved simultaneously.

**Parallel Computing**

COMSOL supports most forms of parallel computing including shared memory parallelism for multicore processors and high performance computing (HPC) clusters and clouds. Any COMSOL license will be multicore enabled. For cluster or cloud computing, a Floating Network License is needed.

You can use clusters or clouds either for Cluster Sweep or for Cluster Computing. If you have a Floating Network License, these two options are available from the Study node by right-clicking. However, you first need to enable Advanced Study
Options by clicking the Show button on the Model Builder toolbar and selecting Advanced Study Options.

**Cluster Sweep**

Cluster Sweep is used for solving several models in parallel where each model has a different set of Parameters. This can be seen as a generalization of Parametric Sweep. Right-click the Study node to add a Cluster Sweep node. The Study Settings for Cluster Sweep is similar to that of Parametric Sweep, but additional settings are required for the cluster or cloud being used. The below picture shows how the top of the settings window for Cluster Sweep would look like for the same sweep as defined in “Parametric Sweeps” on page 96.

**Cluster Computing**

You can also utilize a cluster or cloud to solve a single large model using distributed memory. For maximum performance, the COMSOL cluster implementation can utilize shared-memory multicore processing on each node in combination with the Message Passing Interface (MPI) based distributed memory.
model. This brings a major performance boost by making the most out of the computational power available.

Right-click the Study node to add a Cluster Computing node.

The Cluster Computing settings window, shown below, helps to manage the simulation with settings for the cluster or cloud.

You choose the type of cluster job you want to do from the Cluster type list. COMSOL supports Windows Computer Cluster Server (WCCS) 2003, Windows HPC Server (HPCS) 2008, Open Grid Scheduler/ Grid Engine (OGS/GE), or Not distributed.

To learn more about running COMSOL in parallel, see the COMSOL Multiphysics Reference Manual.
Appendix A—Building a Geometry

This section details how to create the busbar geometry using COMSOL’s built-in geometry tools. The step-by-step instructions take you through the construction of the geometry using parameters set up in Global Definitions. Using parameterized dimensions helps to produce what-if analyses and geometric parametric sweeps.

As an alternative to building the geometry in COMSOL you can import a geometry from a CAD package. The optional CAD Import Module supports many CAD file formats. Moreover, several add-on products are available that provide bidirectional interfaces to common CAD software packages. See “Appendix E—Connecting with LiveLink™ Add-Ons” on page 142 for a list.

Follow the steps under the Model Wizard (to add the physics and study) and Global Definitions (to add the parameters) starting with “Example 2: The Busbar—A Multiphysics Model” on page 42. Then return to this section to learn about geometry modeling. The first step in the geometry sequence is to draw the profile of the busbar.

1. Under Model 1, right-click Geometry 1 and select Work Plane . In the Work Plane settings window:
   - Select xz-plane from the Plane list.
   - Click the Show Work Plane button on the Work Plane settings toolbar.

Continue by editing the axis and grid settings in Work Plane 1.
2 In the Model Builder, expand the View 2 node and click Axis.

3 In the Axis settings window:
   Under Axis:
   - In the x minimum and y minimum fields, enter -0.01.
   - In the x maximum and y maximum fields, enter 0.11.
   Note that the values you type will be automatically adjusted slightly after you enter it to adapt to the screen aspect ratio.
   Under Grid:
   - Select the Manual Spacing check box.
   - In the x spacing and y spacing fields, enter 5e-3.

4 Click the Apply button on the toolbar.

You can use interactive drawing to create a geometry using the drawing toolbar buttons while pointing and clicking in the Graphics window. You can also
right-click the Plane Geometry node \( \text{Plane Geometry} \) under Work Plane 1 \( \text{Work Plane 1} \) to add geometry objects to the geometry sequence.

In the next sequence of steps we create a profile of the busbar.

5 In the Model Builder under Work Plane 1, right-click Plane Geometry \( \text{Plane Geometry} \) and select Rectangle \( \text{Rectangle} \).

In the Rectangle settings window under Size, enter:
- \( \text{L+2*tbb} \) in the Width field.
- \( 0.1 \) in the Height field.

Click the Build Selected button \( \text{Build Selected} \).
6 Create a second rectangle. Under Work Plane 1, right-click Plane Geometry and select Rectangle. Under Size, enter:
- \( L + \text{tbb} \) in the Width field
- \( 0.1 \times \text{tbb} \) in the Height field.
Under Position, enter:
- \( \text{tbb} \) in the yw field.
Click the Build Selected button.
Use the Boolean Difference operation to subtract the second rectangle from the first one.

7 Under Work Plane 1, right-click Plane Geometry and select Boolean Operations>Difference. In the Graphics window, click \( r1 \) and right-click to add \( r1 \) to the Objects to add list in the Difference settings window.

   To help select the geometry you can display geometry labels in the Graphics window. In the Model Builder under Geometry 1>WorkPlane 1>Plane Geometry, click the View 2 node. Go to the View settings window and select the Show geometry labels check box.

8 Click the Difference node. In the Difference settings window, click the Activate selection button to the right of the Objects to subtract list. Then select the smaller rectangle (left-click multiple times to cycle through overlapping geometry objects) and right-click to add \( r2 \) to the list.
Click Build Selected.

   Another way to select \( r2 \) in the Graphics window is to use the Selection List window. Select View>Selection List and in the Selection List settings window,
click to highlight r2 (solid). Then right-click r2 (solid) in the list to add it to the Object to subtract list.

After building the selected geometry, you should have a backward-facing, L-shaped profile. Continue by rounding the corners of the L-shaped profile.

9 Under Work Plane 1, right-click Plane Geometry and select Fillet. Select point 3 to add it to the Vertices to fillet list. There are different ways to add the points:
   - In the Graphics window, click point 3 (in the inner right corner), and right-click to add it to the Vertices to fillet list.
   - Select View Selection List. In the Selection List window, click 3. The corresponding point is highlighted in the Graphics window. Click the Add to
Selection button on the Fillet settings window or right-click in the Selection List.

10 Enter tbb in the Radius field. Click Build Selected. This takes care of the inner corner.

11 For the outer corner, right-click Plane Geometry and select Fillet.

12 In the Graphics window, click point 6, the outer corner, and right-click to add it to the Vertices to fillet list.

13 Enter 2*tbb in the Radius field. Click Build Selected.
Next you extrude the work plane to create the 3D busbar geometry.

1. In the Model Builder, right-click Work Plane 1 and select Extrude. In the Extrude settings window, enter wbb in the Distances from Plane table (replace the default) to extrude to the width of the profile.

<table>
<thead>
<tr>
<th>Distances from Plane</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Distance (m)</strong></td>
</tr>
<tr>
<td>wbb</td>
</tr>
</tbody>
</table>

The table allows you to enter several values in order to create sandwich structures with different layer materials. In this case, only one extruded layer is needed.
2 Click Build Selected and then click the Zoom Extents button on the Graphics toolbar. Click the Save button and name the model busbar.mph (if you have not already done so).

Next, create the titanium bolts by extruding two circles drawn in two work planes.

3 In the Model Builder, right-click Geometry 1 and add a Work Plane. A Work Plane 2 node is added. In the Work Plane settings window, under Work Plane, select Face parallel as the Plane type.
4 In the Graphics window, click face 8 (highlighted in the figure). Once this surface is highlighted in red, right-click anywhere in the Graphics window to add it to the Planar face list in the Work Plane settings window. Face number 8 is now highlighted in blue and the work plane is positioned on top of face number 8.

5 Click the Show Work Plane button ✗ to draw the first circle representing the position of the first bolt. Click the Zoom Extents button ✗ on the Graphics toolbar.
Under Work Plane 2, right-click Plane Geometry and select Circle. In the Circle settings window:
- Under Size and Shape in the Radius field, enter $\text{rad}_1$.
- Under Position, the xw and yw coordinates (0, 0) are already defined.
Click Build Selected.

Continue creating the bolt by adding an extrude operation.
In the Model Builder, right-click Work Plane 2 and select Extrude. In the Extrude settings window, in the first row of the Distances from Plane table, enter $-2^*\text{tbb}$ to extrude the circle.
2 Click the Build Selected button to create the cylindrical part of the titanium bolt that runs through the busbar.

![Diagram showing the creation of the cylindrical bolt](image)

Draw the two remaining bolts.

3 Right-click Geometry 1 and select Work Plane. A Work Plane node is added. In the Work Plane settings window, for Work Plane 3, select Face parallel as the Plane type.

4 In the Graphics window, click Face (shown in the figure). When this surface is highlighted red, right-click anywhere in the Graphics window to add it to the Planar face list in the Work Plane settings window.

![Diagram showing the selection of the planar face](image)
Click the Show Work Plane button on the Work Plane settings window and the Zoom Extents button on the Graphics toolbar to get a better view of the geometry.

To parameterize the position of the two remaining bolts, add the circles that form the cross sections of the bolts.

6 Under Work Plane 3, right-click Plane Geometry and select Circle.

In the Circle settings window:
- Under Size and Shape, enter \( rad_1 \) in the Radius field.
- Under Position, enter \(-L/2+1.5e-2\) in the \( xw \) field and \(-wbb/4\) in the \( yw \) field.

Click Build Selected.

Copy the circle that you just created to generate the third bolt in the busbar.

7 Under Work Plane 3, right-click Plane Geometry and select Transforms>Copy.

8 In the Graphics window, click the circle to highlight it. Right-click anywhere in the Graphics window and add the circle to the Input object list in the Copy settings window.

9 In the Copy settings window under Displacement, enter \( wbb/2 \) in the \( yw \) field.
10 Click Build Selected \( \text{F} \).

Your geometry, as shown in the workplane, should match this figure so far. Continue by extruding the circles.
In the Model Builder, right-click Work Plane 3 and select Extrude. In the Extrude settings window, in the first row of the Distances from Plane table, enter \(-2 \times \text{tbb}\) (replace the default). Click Build All.

The geometry and its corresponding geometry sequence should match the figures below. Click the Save button and name the model busbar.mph.

To continue with the busbar tutorial, return to the section “Materials” on page 49.
## Appendix B—Keyboard and Mouse Shortcuts

<table>
<thead>
<tr>
<th>SHORTCUT (WINDOWS, LINUX)</th>
<th>SHORTCUT (MAC)</th>
<th>ACTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>F1</td>
<td>Display help for the selected node or window</td>
</tr>
<tr>
<td>Ctrl+F1</td>
<td>Command+F1</td>
<td>Open the COMSOL Documentation front page in an external window</td>
</tr>
<tr>
<td>F2</td>
<td>F2</td>
<td>Rename the selected node, file, or folder</td>
</tr>
<tr>
<td>F3</td>
<td>F3</td>
<td>Disable selected nodes</td>
</tr>
<tr>
<td>F4</td>
<td>F4</td>
<td>Enable selected nodes</td>
</tr>
<tr>
<td>F5</td>
<td>F5</td>
<td>Update the Data Sets Solutions with respect to any new Global Definitions and Definitions without re-solving the model</td>
</tr>
<tr>
<td>F7</td>
<td>F7</td>
<td>Build the selected node in the geometry and mesh branches, or compute to the selected node in the solver sequence</td>
</tr>
<tr>
<td>F8</td>
<td>F8</td>
<td>Build the geometry, build the mesh, compute the entire solver sequence, update results data, or update the plot</td>
</tr>
<tr>
<td>Del</td>
<td>Del</td>
<td>Delete selected nodes</td>
</tr>
<tr>
<td>Left arrow (Windows); Shift + left arrow (Linux)</td>
<td>Left arrow</td>
<td>Collapse a branch in the Model Tree</td>
</tr>
<tr>
<td>Right arrow (Windows); Shift + right arrow (Linux)</td>
<td>Right arrow</td>
<td>Expand a branch in the Model Tree</td>
</tr>
<tr>
<td>Up arrow</td>
<td>Up arrow</td>
<td>Move to the node above in the Model Tree</td>
</tr>
<tr>
<td>Down arrow</td>
<td>Down arrow</td>
<td>Move to the node below in the Model Tree</td>
</tr>
<tr>
<td>Alt+left arrow</td>
<td>Ctrl+left arrow</td>
<td>Move to the previously selected node in the Model Tree</td>
</tr>
<tr>
<td>Alt+right arrow</td>
<td>Ctrl+right arrow</td>
<td>Move to the next selected node in the Model Tree</td>
</tr>
<tr>
<td>SHORTCUT (WINDOWS, LINUX)</td>
<td>SHORTCUT (MAC)</td>
<td>ACTION</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------</td>
<td>--------</td>
</tr>
<tr>
<td>Ctrl+A</td>
<td>Command+A</td>
<td>Select all domains, boundaries, edges, or points; select all cells in a table</td>
</tr>
<tr>
<td>Ctrl+D</td>
<td>Command+D</td>
<td>Deselect all domains, boundaries, edges, or points</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Command+C</td>
<td>Copy text in fields</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>Command+N</td>
<td>New model</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>Command+O</td>
<td>Open file</td>
</tr>
<tr>
<td>Ctrl+P</td>
<td>Command+P</td>
<td>Print</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Command+S</td>
<td>Save file</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Command+V</td>
<td>Paste copied text</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Command+Z</td>
<td>Undo the last operation</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Ctrl+Shift+Z</td>
<td>Redo the last undone operation</td>
</tr>
<tr>
<td>Ctrl+up arrow</td>
<td>Command+up arrow</td>
<td>Move a definitions node, geometry node, physics node (except default nodes), material node, mesh node, study step node, or results node up one step</td>
</tr>
<tr>
<td>Ctrl+down arrow</td>
<td>Command+down arrow</td>
<td>Move a definitions node, geometry node, physics node (except default nodes), material node, mesh node, study step node, or results node down one step</td>
</tr>
<tr>
<td>Ctrl+Tab</td>
<td>Ctrl+Tab</td>
<td>Switch focus to the next window on the desktop</td>
</tr>
<tr>
<td>Ctrl+Shift+N</td>
<td>Command+Shift+N</td>
<td>New Physics Builder</td>
</tr>
<tr>
<td>Ctrl+Shift+Tab</td>
<td>Ctrl+Shift+Tab</td>
<td>Switch focus to the previous window on the desktop</td>
</tr>
<tr>
<td>Ctrl+Alt+left arrow</td>
<td>Command+Alt+left arrow</td>
<td>Switch focus to the Model Builder window</td>
</tr>
<tr>
<td>Ctrl+Alt+right arrow</td>
<td>Command+Alt+right arrow</td>
<td>Switch focus to the settings window</td>
</tr>
<tr>
<td>Ctrl+Alt+up arrow</td>
<td>Command+Alt+up arrow</td>
<td>Switch focus to the previous section in the settings window</td>
</tr>
<tr>
<td>Ctrl+Alt+down arrow</td>
<td>Command+Alt+down arrow</td>
<td>Switch focus to the next section in the settings window</td>
</tr>
<tr>
<td>SHORTCUT (WINDOWS, LINUX)</td>
<td>SHORTCUT (MAC)</td>
<td>ACTION</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------</td>
<td>--------</td>
</tr>
<tr>
<td>Shift+F10 or Ctrl+F10</td>
<td>Ctrl+F10</td>
<td>Open the context menu</td>
</tr>
<tr>
<td>Ctrl+Space</td>
<td>Ctrl+Space</td>
<td>Open list of predefined quantities for insertion in Expression fields for plotting and results evaluation</td>
</tr>
<tr>
<td>Left-click and hold down the mouse button while dragging the mouse.</td>
<td>Same as for Windows, only available for two-button mouse.</td>
<td>Rotate the scene around the axes parallel to the screen X- and Y-axes with the origin at the scene rotation point.</td>
</tr>
<tr>
<td>Right-click and hold down the mouse button while dragging the mouse.</td>
<td>Same as for Windows, only available for two-button mouse.</td>
<td>Move the visible frame on the image plane in any direction.</td>
</tr>
<tr>
<td>Middle-click and hold down the mouse button while dragging the mouse.</td>
<td>Same as for Windows, only available for two-button mouse.</td>
<td>The scene is zoomed in/out around the mouse position where the action started.</td>
</tr>
<tr>
<td>Press Ctrl and left-click. While holding down both buttons, drag the mouse.</td>
<td>Same as for Windows, only available for two-button mouse.</td>
<td>Tilt and pan the camera by rotating about the X- and Y axes in the image plane.</td>
</tr>
<tr>
<td>Press Ctrl and right-click. While holding down both buttons, drag the mouse.</td>
<td>Same as for Windows, only available for two-button mouse.</td>
<td>Move the camera in the plane parallel to the image plane.</td>
</tr>
<tr>
<td>Press Ctrl and middle-click. While holding down both buttons, drag the mouse.</td>
<td>Same as for Windows, only available for two-button mouse.</td>
<td>Move the camera into and away from the object (dolly in/out).</td>
</tr>
<tr>
<td>Press Ctrl+Alt and left-click. While holding down both buttons, drag the mouse.</td>
<td>Same as for Windows, only available for two-button mouse.</td>
<td>Rotate the camera around the axis.</td>
</tr>
<tr>
<td>Press Alt and left-click. While holding down both buttons, drag the mouse.</td>
<td>Same as for Windows, only available for two-button mouse.</td>
<td>Rotate the camera about its axis between the camera and the scene rotation point (roll direction).</td>
</tr>
<tr>
<td>Press Alt and right-click. While holding down both buttons, drag the mouse.</td>
<td>Same as for Windows, only available for two-button mouse.</td>
<td>Move the scene in the plane orthogonal to the axis between the camera and the scene rotation point.</td>
</tr>
<tr>
<td>Press Alt and middle-click. While holding down both buttons, drag the mouse.</td>
<td>Same as for Windows, only available for two-button mouse.</td>
<td>Move the camera along the axis between the camera and the scene rotation point.</td>
</tr>
</tbody>
</table>
Building a Model Tree in COMSOL is equivalent to graphically programming a sequence of operations. Saving as Model M-file or Model Java-file outputs the sequence of operations as a list of traditional programming statements. In this section we will give an overview of the following element categories as defined by the underlying COMSOL language:

- Constants
- Variables
- Functions
- Operators
- Expressions

These language elements are built-in or user-defined. Operators cannot be user-defined. Expressions are always user-defined.

**ABOUT RESERVED NAMES**

Built-in elements have reserved names, names that cannot be redefined by the user. If you try to use a reserved name for a user-defined variable, parameter, or function, the text where you enter the name will turn orange and you will get a tooltip error message if you select the text string. Reserved function names are reserved only for function names, which means that such names can be used for variable and parameter names, and vice versa. In the following pages we list the most commonly used built-in elements and hence those reserved names.

**Constants and Parameters**

There are three different types of Constants: Built-in Mathematical and Numerical Constants, Built-in Physical Constants, and Parameters. Parameters are User-defined Constants which can vary over parameter sweeps. Constants are scalar valued. The tables below list the Built-in Mathematical and Numerical Constants as well as Built-in Physical Constants. Constants and Parameters can have units.
### Built-in Mathematical and Numerical Constants

<table>
<thead>
<tr>
<th>DESCRIPTION</th>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Floating point relative accuracy for double floating point numbers, also known as machine epsilon</td>
<td>eps</td>
<td>$2^{-52} \approx 2.2204 \cdot 10^{-16}$</td>
</tr>
<tr>
<td>The imaginary unit</td>
<td>i, j</td>
<td>i, sqrt(-1)</td>
</tr>
<tr>
<td>Infinity, $\infty$</td>
<td>inf, Inf</td>
<td>A value larger than what can be handled with floating point representation</td>
</tr>
<tr>
<td>Not-a-number</td>
<td>NaN, nan</td>
<td>An undefined or unrepresentable value such as the result of 0/0 or inf/inf</td>
</tr>
<tr>
<td>$\pi$</td>
<td>pi</td>
<td>3.141592653589793</td>
</tr>
</tbody>
</table>

### Built-in Physical Constants

<table>
<thead>
<tr>
<th>DESCRIPTION</th>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acceleration of gravity</td>
<td>g_const</td>
<td>$9.80665,[\text{m/s}^2]$</td>
</tr>
<tr>
<td>Avogadro constant</td>
<td>N_A_const</td>
<td>$6.02214129 \times 10^{23},[\text{1/mol}]$</td>
</tr>
<tr>
<td>Boltzmann constant</td>
<td>k_B_const</td>
<td>$1.3806488 \times 10^{-23},[\text{J/K}]$</td>
</tr>
<tr>
<td>Characteristic impedance of vacuum (impedance of free space)</td>
<td>Z0_const</td>
<td>$376.73031346177066,[\text{ohm}]$</td>
</tr>
<tr>
<td>Electron mass</td>
<td>me_const</td>
<td>$9.10938291 \times 10^{-31},[\text{kg}]$</td>
</tr>
<tr>
<td>Elementary charge</td>
<td>e_const</td>
<td>$1.602176565 \times 10^{-19},[\text{C}]$</td>
</tr>
<tr>
<td>Faraday constant</td>
<td>F_const</td>
<td>$96485.3365,[\text{C/mol}]$</td>
</tr>
<tr>
<td>Fine-structure constant</td>
<td>alpha_const</td>
<td>$7.2973525698\cdot10^{-3}$</td>
</tr>
<tr>
<td>Gravitational constant</td>
<td>G_const</td>
<td>$6.67384 \times 10^{-11},[\text{m}^3/(\text{kg} \cdot \text{s}^2)]$</td>
</tr>
<tr>
<td>Molar volume of ideal gas (at 273.15 K and 1 atm)</td>
<td>V_m_const</td>
<td>$2.2413968 \times 10^{-2},[\text{m}^3/\text{mol}]$</td>
</tr>
<tr>
<td>Neutron mass</td>
<td>mn_const</td>
<td>$1.674927351 \times 10^{-27},[\text{kg}]$</td>
</tr>
<tr>
<td>Permeability of vacuum (magnetic constant)</td>
<td>mu0_const</td>
<td>$4\pi \times 10^{-7},[\text{H/m}]$</td>
</tr>
<tr>
<td>Permittivity of vacuum (electric constant)</td>
<td>epsilon0_const</td>
<td>$8.8541878170000001 \times 10^{-12},[\text{F/m}]$</td>
</tr>
</tbody>
</table>
PARAMETERS

Parameters are user-defined constant scalars in the Global Definitions branch in the Model Tree. Example uses are:

• parameterizing geometric dimensions,
• parameterizing mesh element sizes,
• defining parameters to be used in parametric sweeps.

A Parameter can be defined as an expression in terms of numbers, Parameters, built-in constants, and functions of parameters and built-in constants. Parameters should be assigned a unit, using [], unless they are dimensionless.

Variables

There are two types of Variables: built-in and user-defined. Variables can be scalars or fields. Variables can have units.

Note: There is a group of user-defined variables of special interest. Spatial coordinate variables and dependent variables. These variables have default names based on the space dimension of the geometry and the Physics interface respectively. As a result of the names chosen for these variables, a list of built-in variables will be created by COMSOL: the first and second order derivatives with respect to space and time.

<table>
<thead>
<tr>
<th>DESCRIPTION</th>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planck’s constant</td>
<td>h_const</td>
<td>6.62606957e-34[J*s]</td>
</tr>
<tr>
<td>Planck’s constant over 2 pi</td>
<td>h_bar</td>
<td>1.0545717253629e-34[J*s]</td>
</tr>
<tr>
<td>Proton mass</td>
<td>mp_const</td>
<td>1.672621777e-27[kg]</td>
</tr>
<tr>
<td>Speed of light in vacuum</td>
<td>c_const</td>
<td>299792458[m/s]</td>
</tr>
<tr>
<td>Stefan-Boltzmann constant</td>
<td>sigma_const</td>
<td>5.670373e-8[W/(m^2*K^4)]</td>
</tr>
<tr>
<td>Universal gas constant</td>
<td>R_const</td>
<td>8.3144621[J/(mol*K)]</td>
</tr>
<tr>
<td>Wien displacement law constant</td>
<td>b_const</td>
<td>2.8977721e-3[m*K]</td>
</tr>
</tbody>
</table>
## Built-in Variables

<table>
<thead>
<tr>
<th>NAME</th>
<th>DESCRIPTION</th>
<th>TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>t</td>
<td>Time</td>
<td>Scalar</td>
</tr>
<tr>
<td>freq</td>
<td>Frequency</td>
<td>Scalar</td>
</tr>
<tr>
<td>lambda</td>
<td>Eigenvalue</td>
<td>Scalar</td>
</tr>
<tr>
<td>phase</td>
<td>Phase angle</td>
<td>Scalar</td>
</tr>
<tr>
<td>numberofdofs</td>
<td>Number of degrees of freedom</td>
<td>Scalar</td>
</tr>
<tr>
<td>h</td>
<td>Mesh element size (length of the longest edge of</td>
<td>Field</td>
</tr>
<tr>
<td></td>
<td>the element)</td>
<td></td>
</tr>
<tr>
<td>meshType</td>
<td>Mesh type index for the mesh element; this is the</td>
<td>Field</td>
</tr>
<tr>
<td></td>
<td>number of edges in the element.</td>
<td></td>
</tr>
<tr>
<td>meshElement</td>
<td>Mesh element number</td>
<td>Field</td>
</tr>
<tr>
<td>dvol</td>
<td>Volume scale factor variable; this is the</td>
<td>Field</td>
</tr>
<tr>
<td></td>
<td>determinant of the Jacobian matrix for the</td>
<td></td>
</tr>
<tr>
<td></td>
<td>mapping from local (element) coordinates to</td>
<td></td>
</tr>
<tr>
<td></td>
<td>global coordinates.</td>
<td></td>
</tr>
<tr>
<td>qual</td>
<td>A mesh quality measure between 0 (poor quality)</td>
<td>Field</td>
</tr>
<tr>
<td></td>
<td>and 1 (perfect quality)</td>
<td></td>
</tr>
</tbody>
</table>

## User-defined Variables That Generate Built-in Variables

<table>
<thead>
<tr>
<th>DEFAULT NAME</th>
<th>DESCRIPTION</th>
<th>TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>x, y, z</td>
<td>Spatial coordinates (Cartesian)</td>
<td>Field</td>
</tr>
<tr>
<td>r, phi, z</td>
<td>Spatial coordinates (Cylindrical)</td>
<td>Field</td>
</tr>
<tr>
<td>u, T, etc.</td>
<td>Dependent variables (Solution)</td>
<td>Field</td>
</tr>
</tbody>
</table>

Example: T is the name for the temperature in a 2D, time-dependent heat transfer model, x and y are the spatial coordinate names. In this case, the following built-in variables will be generated: T, Tx, Ty, Txx, Txy, Tyx, Tyy, Tt, Txt, Tyt, Txxt, Txyt, Tyxt, Tyyt, Tttx, Ttxy, Txyt, Tyyt, and Tttt. Here, Tx corresponds to the partial derivative of the temperature T with respect to x, and Tttt corresponds to the second-order time derivative of T, and so on. If the spatial coordinate variables have other names—for example, psi and chi—then Txy would be Tpsichi, and Txt would be Tpsit. (The time variable t is built-in; the user cannot change its name.)
**Functions**

There are two types of Functions: Built-in and User-defined. Functions can be scalar valued or field valued depending on the input argument(s). Some Functions can have units for both input and output arguments.

**BUILT-IN MATHEMATICAL FUNCTIONS**

These functions do not have units for their input or output arguments.

<table>
<thead>
<tr>
<th>NAME</th>
<th>DESCRIPTION</th>
<th>SYNTAX EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>abs</td>
<td>Absolute value</td>
<td>abs(x)</td>
</tr>
<tr>
<td>acos</td>
<td>Inverse cosine (in radians)</td>
<td>acos(x)</td>
</tr>
<tr>
<td>acosh</td>
<td>Inverse hyperbolic cosine</td>
<td>acosh(x)</td>
</tr>
<tr>
<td>acot</td>
<td>Inverse cotangent (in radians)</td>
<td>acot(x)</td>
</tr>
<tr>
<td>acoth</td>
<td>Inverse hyperbolic cotangent</td>
<td>acoth(x)</td>
</tr>
<tr>
<td>acsc</td>
<td>Inverse cosecant (in radians)</td>
<td>acsc(x)</td>
</tr>
<tr>
<td>acsch</td>
<td>Inverse hyperbolic cosecant</td>
<td>acsch(x)</td>
</tr>
<tr>
<td>arg</td>
<td>Phase angle (in radians)</td>
<td>arg(x)</td>
</tr>
<tr>
<td>asec</td>
<td>Inverse secant (in radians)</td>
<td>asec(x)</td>
</tr>
<tr>
<td>asech</td>
<td>Inverse hyperbolic secant</td>
<td>asech(x)</td>
</tr>
<tr>
<td>asin</td>
<td>Inverse sine (in radians)</td>
<td>asin(x)</td>
</tr>
<tr>
<td>asinh</td>
<td>Inverse hyperbolic sine</td>
<td>asinh(x)</td>
</tr>
<tr>
<td>atan</td>
<td>Inverse tangent (in radians)</td>
<td>atan(x)</td>
</tr>
<tr>
<td>atan2</td>
<td>Four-quadrant inverse tangent (in radians)</td>
<td>atan2(y,x)</td>
</tr>
<tr>
<td>atanh</td>
<td>Inverse hyperbolic tangent</td>
<td>atanh(x)</td>
</tr>
<tr>
<td>besselj</td>
<td>Bessel function of the first kind</td>
<td>besselj(a,x)</td>
</tr>
<tr>
<td>bessely</td>
<td>Bessel function of the second kind</td>
<td>bessely(a,x)</td>
</tr>
<tr>
<td>besseli</td>
<td>Modified Bessel function of the first kind</td>
<td>besseli(a,x)</td>
</tr>
<tr>
<td>besselk</td>
<td>Modified Bessel function of the second kind</td>
<td>besselk(a,x)</td>
</tr>
<tr>
<td>ceil</td>
<td>Nearest following integer</td>
<td>ceil(x)</td>
</tr>
<tr>
<td>conj</td>
<td>Complex conjugate</td>
<td>conj(x)</td>
</tr>
<tr>
<td>cos</td>
<td>Cosine</td>
<td>cos(x)</td>
</tr>
<tr>
<td>cosh</td>
<td>Hyperbolic cosine</td>
<td>cosh(x)</td>
</tr>
<tr>
<td>cot</td>
<td>Cotangent</td>
<td>cot(x)</td>
</tr>
<tr>
<td>coth</td>
<td>Hyperbolic cotangent</td>
<td>coth(x)</td>
</tr>
</tbody>
</table>
The following functions are only available when solving and not when evaluating parameters and variables in the user interface: \( \text{acosh}, \text{acoth}, \text{acsch}, \text{asech}, \text{asinh}, \text{atanh}, \text{besselj}, \text{bessely}, \text{besseli}, \text{besselk}, \text{erf}, \text{gamma}, \text{and} \ \text{psi}. \)

**Built-in Operator Functions**

These built-in functions behave differently than the built-in mathematical functions. They may not belong in an introductory text but are listed to complete

<table>
<thead>
<tr>
<th>NAME</th>
<th>DESCRIPTION</th>
<th>SYNTAX EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>csc</td>
<td>Cosecant</td>
<td>( \text{csc}(x) )</td>
</tr>
<tr>
<td>csch</td>
<td>Hyperbolic cosecant</td>
<td>( \text{csch}(x) )</td>
</tr>
<tr>
<td>erf</td>
<td>Error function</td>
<td>( \text{erf}(x) )</td>
</tr>
<tr>
<td>exp</td>
<td>Exponential</td>
<td>( \text{exp}(x) )</td>
</tr>
<tr>
<td>floor</td>
<td>Nearest previous integer</td>
<td>( \text{floor}(x) )</td>
</tr>
<tr>
<td>gamma</td>
<td>Gamma function</td>
<td>( \text{gamma}(x) )</td>
</tr>
<tr>
<td>imag</td>
<td>Imaginary part</td>
<td>( \text{imag}(u) )</td>
</tr>
<tr>
<td>log</td>
<td>Natural logarithm</td>
<td>( \text{log}(x) )</td>
</tr>
<tr>
<td>log10</td>
<td>Base-10 logarithm</td>
<td>( \text{log10}(x) )</td>
</tr>
<tr>
<td>log2</td>
<td>Base-2 logarithm</td>
<td>( \text{log2}(x) )</td>
</tr>
<tr>
<td>max</td>
<td>Maximum of two arguments</td>
<td>( \text{max}(a,b) )</td>
</tr>
<tr>
<td>min</td>
<td>Minimum of two arguments</td>
<td>( \text{min}(a,b) )</td>
</tr>
<tr>
<td>mod</td>
<td>Modulo operator</td>
<td>( \text{mod}(a,b) )</td>
</tr>
<tr>
<td>psi</td>
<td>Psi function and its derivatives</td>
<td>( \text{psi}(x,k) )</td>
</tr>
<tr>
<td>range</td>
<td>Create a range of numbers</td>
<td>( \text{range}(a,\text{step},b) )</td>
</tr>
<tr>
<td>real</td>
<td>Real part</td>
<td>( \text{real}(u) )</td>
</tr>
<tr>
<td>round</td>
<td>Round to closest integer</td>
<td>( \text{round}(x) )</td>
</tr>
<tr>
<td>sec</td>
<td>Secant</td>
<td>( \text{sec}(x) )</td>
</tr>
<tr>
<td>sech</td>
<td>Hyperbolic secant</td>
<td>( \text{sech}(x) )</td>
</tr>
<tr>
<td>sign</td>
<td>Signum function</td>
<td>( \text{sign}(u) )</td>
</tr>
<tr>
<td>sin</td>
<td>Sine</td>
<td>( \text{sin}(x) )</td>
</tr>
<tr>
<td>sinh</td>
<td>Hyperbolic sine</td>
<td>( \text{sinh}(x) )</td>
</tr>
<tr>
<td>sqrt</td>
<td>Square root</td>
<td>( \text{sqrt}(x) )</td>
</tr>
<tr>
<td>tan</td>
<td>Tangent</td>
<td>( \text{tan}(x) )</td>
</tr>
<tr>
<td>tanh</td>
<td>Hyperbolic tangent</td>
<td>( \text{tanh}(x) )</td>
</tr>
</tbody>
</table>

The following functions are only available when solving and not when evaluating parameters and variables in the user interface: \( \text{acosh}, \text{acoth}, \text{acsch}, \text{asech}, \text{asinh}, \text{atanh}, \text{besselj}, \text{bessely}, \text{besseli}, \text{besselk}, \text{erf}, \text{gamma}, \text{and} \ \text{psi}. \)
the list of reserved names. For more information see the *COMSOL Multiphysics Reference Manual*.

<table>
<thead>
<tr>
<th>NAME</th>
<th>NAME</th>
<th>NAME</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>adj</td>
<td>down</td>
<td>linsol</td>
<td>scope.at/</td>
</tr>
<tr>
<td>at</td>
<td>dtang</td>
<td>lintotal</td>
<td>sens</td>
</tr>
<tr>
<td>ballavg</td>
<td>error</td>
<td>lintotalavg</td>
<td>shapeorder</td>
</tr>
<tr>
<td>ballint</td>
<td>fsens</td>
<td>lintotalpeak</td>
<td>side</td>
</tr>
<tr>
<td>bdf</td>
<td>if</td>
<td>lintotalrms</td>
<td>sphavg</td>
</tr>
<tr>
<td>centroid</td>
<td>integrate</td>
<td>linzero</td>
<td>sphint</td>
</tr>
<tr>
<td>circavg</td>
<td>isdefined</td>
<td>mean</td>
<td>subst</td>
</tr>
<tr>
<td>circint</td>
<td>isnf</td>
<td>nojac</td>
<td>test</td>
</tr>
<tr>
<td>circumcenter</td>
<td>islinear</td>
<td>pd</td>
<td>timeavg</td>
</tr>
<tr>
<td>d</td>
<td>isnan</td>
<td>ppr</td>
<td>timeint</td>
</tr>
<tr>
<td>depends</td>
<td>jacdepends</td>
<td>pprint</td>
<td>try_catch</td>
</tr>
<tr>
<td>dest</td>
<td>lindev</td>
<td>prev</td>
<td>up</td>
</tr>
<tr>
<td>diskavg</td>
<td>linper</td>
<td>reacf</td>
<td>var</td>
</tr>
<tr>
<td>diskint</td>
<td>linpoint</td>
<td>realdot</td>
<td>with</td>
</tr>
</tbody>
</table>
**USER-DEFINED FUNCTIONS**

A User-defined Function can be defined in the Global Definitions or Model Definitions branch of the Model Tree by selecting a template from the Functions menu and entering settings to define the name and detailed shape of the function.

<table>
<thead>
<tr>
<th>TEMPLATE NAME</th>
<th>ARGUMENTS AND DEFINITION</th>
<th>SYNTAX EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analytic</td>
<td>The function name is its identifier; for example <em>an1</em>. The function is a mathematical expression of its arguments. Example: Given the arguments <em>x</em> and <em>y</em>, its definition is ( \sin(x)\cos(y) ). The function has an arbitrary number of arguments.</td>
<td>The name of the function with comma-separated arguments within parenthesis. For example: ( \text{an1}(x, y) )</td>
</tr>
<tr>
<td>Elevation</td>
<td>The function name is its identifier; for example <em>elev1</em>. Used to import geospatial elevation data from digital elevation models and map the elevation data to a function of <em>x</em> and <em>y</em>. A DEM file contains elevation data for a portion of the Earth’s surface. The resulting function behaves essentially like a grid-based interpolation function.</td>
<td>The name of the function with comma-separated arguments within parenthesis. For example: ( \text{elev1}(x, y) )</td>
</tr>
<tr>
<td>Gaussian Pulse</td>
<td>The function name is its identifier; for example <em>gp1</em>. The Gaussian pulse function defines a bell-shaped curve according to the expression ( y(x) = \frac{1}{\sigma \sqrt{2\pi}} e^{-\frac{(x-x_0)^2}{2\sigma^2}} ). It is defined by the mean parameter, ( x_0 ), and the standard deviation, ( \sigma ). The function has one argument.</td>
<td>The name of the function with a single argument within parenthesis. For example: ( \text{gp1}(x) )</td>
</tr>
<tr>
<td>Template Name</td>
<td>Arguments and Definition</td>
<td>Syntax Example</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Image</td>
<td>The function name is its identifier; for example, \texttt{im1}. Used to import an image (in BMP, JPEG, PNG, or GIF format) and map the image's RGB data to a scalar (single channel) function output value. By default the function's output uses the mapping ((R+G+B)/3).</td>
<td>The name of the function with comma-separated arguments within parenthesis. For example: \texttt{im1}(x,y)</td>
</tr>
<tr>
<td>Interpolation</td>
<td>The function name is its identifier; for example, \texttt{int1}. An interpolation function is defined by a table or file containing the values of the function in discrete points. The file formats are the following: spreadsheet, grid, or sectionwise. The function has one to three arguments.</td>
<td>The name of the function with comma-separated arguments within parenthesis. For example: \texttt{int1}(x,y,z)</td>
</tr>
<tr>
<td>Piecewise</td>
<td>The function name is its identifier; for example, \texttt{pw1}. A piecewise function is created by splicing together several functions, each defined on one interval. Define the argument, extrapolation and smoothing methods, and the functions and their intervals. This function has one argument with different definitions on different intervals, which must not overlap or have any holes between them.</td>
<td>The name of the function with a single argument within parenthesis. For example: \texttt{pw1}(x)</td>
</tr>
<tr>
<td>Ramp</td>
<td>The function name is its identifier; for example, \texttt{rm1}. A ramp function is a linear increase with a user-defined slope that begins at some specified time. The function has one argument. It can also be smoothed.</td>
<td>The name of the function with a single argument within parenthesis. For example: \texttt{rm1}(x)</td>
</tr>
<tr>
<td>Template Name</td>
<td>Arguments and Definition</td>
<td>Syntax Example</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Random</td>
<td>The function name is its identifier, for example <code>rn1</code>. A random function generates white noise with uniform or normal distribution and has one or more arguments to simulate white noise. The function has arbitrary number of arguments.</td>
<td>The name of the function with comma-separated arguments within parenthesis. For example: <code>rn1(x,y)</code> The arguments $x$ and $y$ are used as a random seeds for the random function.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>The function name is its identifier, for example <code>rect1</code>. A rectangle function is $1$ in an interval and $0$ everywhere else. The function has one argument.</td>
<td>The name of the function with a single argument within parenthesis. For example: <code>rect1(x)</code></td>
</tr>
<tr>
<td>Step</td>
<td>The function name is its identifier, for example <code>step1</code>. A step function is a sharp transition from $0$ to some other value (amplitude) at some location. The function has one argument. It can also be smoothed.</td>
<td>The name of the function with a single argument within parenthesis. For example: <code>step1(x)</code></td>
</tr>
<tr>
<td>Triangle</td>
<td>The function name is its identifier, for example <code>tri1</code>. A triangle function is a linear increase and linear decline within an interval and $0$ everywhere else. The function has one argument. It can also be smoothed.</td>
<td>The name of the function with a single argument within parenthesis. For example: <code>tri1(x)</code></td>
</tr>
<tr>
<td>Waveform</td>
<td>The function name is its identifier, for example <code>wv1</code>. A waveform function is a periodic function with one of several characteristic shapes: sawtooth, sine, square, or triangle. The function has one argument. It can also be smoothed.</td>
<td>The name of the function with a single argument within parenthesis. For example: <code>wv1(x)</code></td>
</tr>
</tbody>
</table>
### External (Global Definitions only)
An external function defines an interface to one or more functions written in the C language (which can be a wrapper function interfacing source code written, for example, in Fortran). Such an external function can be used, for example, to interface a user-created shared library. Note that the extension of a shared library file depends on the platform: .dll (Windows), .so (Linux), or .dylib (Mac OS X).

<table>
<thead>
<tr>
<th>TEMPLATE NAME</th>
<th>ARGUMENTS AND DEFINITION</th>
<th>SYNTAX EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>External (Global Definitions only)</td>
<td>The name of the function and the appropriate number of arguments within parenthesis. For example: myextfunc(a,b)</td>
<td></td>
</tr>
</tbody>
</table>

### MATLAB (Global Definitions only)
A MATLAB function interfaces one or more functions written in the MATLAB language. Such functions can be used as any other function defined in COMSOL provided LiveLink for MATLAB and MATLAB are installed. (MATLAB functions are evaluated by MATLAB at runtime.)

<table>
<thead>
<tr>
<th>TEMPLATE NAME</th>
<th>ARGUMENTS AND DEFINITION</th>
<th>SYNTAX EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>MATLAB (Global Definitions only)</td>
<td>The name of the function and the appropriate number of arguments within parenthesis. For example: mymatlabfunc(a,b)</td>
<td></td>
</tr>
</tbody>
</table>
Unary and Binary Operators

<table>
<thead>
<tr>
<th>PRECEDENCE LEVEL</th>
<th>SYMBOL</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>() {} .</td>
<td>Grouping, Lists, Scope</td>
</tr>
<tr>
<td>2</td>
<td>^</td>
<td>Power</td>
</tr>
<tr>
<td>3</td>
<td>! - +</td>
<td>Unary: Logical Not, Minus, Plus</td>
</tr>
<tr>
<td>4</td>
<td>[]</td>
<td>Unit</td>
</tr>
<tr>
<td>5</td>
<td>* /</td>
<td>Multiplication, Division</td>
</tr>
<tr>
<td>6</td>
<td>+ -</td>
<td>Binary: Addition, Subtraction</td>
</tr>
<tr>
<td>7</td>
<td>&lt; &lt;= &gt; &gt;=</td>
<td>Comparisons: Less-Than, Less-Than or Equal, More-Than, More-Than, or Equal</td>
</tr>
<tr>
<td>8</td>
<td>== !=</td>
<td>Comparisons: Equal, Not Equal</td>
</tr>
<tr>
<td>9</td>
<td>&amp;&amp;</td>
<td>Logical And</td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>,</td>
<td>Element Separator in Lists</td>
</tr>
</tbody>
</table>

Expressions

PARAMETERS
A Parameter Expression can contain: Numbers, Parameters, Constants, Functions of Parameter Expressions, Unary and Binary Operators. Parameters can have units.

VARIABLES
A Variable Expression can contain: Numbers, Parameters, Constants, Variables, Functions of Variable Expressions, Unary and Binary Operators. Variables can have units.

FUNCTIONS
A Function definition can contain: input arguments, Numbers, Parameters, Constants, Functions of Parameter Expressions including input arguments, Unary and Binary Operators.
Appendix D—File Formats

COMSOL File Formats

The COMSOL Model file type, with the extension .mph, is the default file type containing the entire Model Tree. The file contains both binary and text data. The mesh and solution data are stored as binary data, while all other information is stored as plain text.

The COMSOL binary and text file types, with the extension .mphbin and .mphtxt, respectively, contain either geometry objects or mesh objects which can be imported directly to the Geometry or Mesh branches in the Model Tree.

The Physics Builder file type, with the extension .mphphb, contains one or more physics user interfaces that you can access from the Model Wizard. See the Physics Builder Manual, for more information.

See “Supported External File Formats” for more information about all the other formats supported by COMSOL.

<table>
<thead>
<tr>
<th>FILE TYPE</th>
<th>EXTENSION</th>
<th>READ</th>
<th>WRITE</th>
</tr>
</thead>
<tbody>
<tr>
<td>COMSOL Model</td>
<td>.mph</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Binary Data</td>
<td>.mphbin</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Text Data</td>
<td>.mphtxt</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Physics Builder</td>
<td>.mphphb</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Supported External File Formats

CAD

The CAD Import Module allows for import of a range of industry-standard CAD file types. Additional file types are available through the bidirectional functionality of the LiveLink products for CAD as well as with the File Import for CATIA V5 add-on.
The DXF (2D), VRML (3D), and STL (3D) file types are available for import with COMSOL Multiphysics and don’t require any add-on products.

<table>
<thead>
<tr>
<th>FILE TYPE</th>
<th>EXTENSION</th>
<th>READ</th>
<th>WRITE</th>
</tr>
</thead>
<tbody>
<tr>
<td>AutoCAD® (3D only)</td>
<td>.dwg</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Autodesk Inventor®</td>
<td>.ipt, .iam</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Creo™ Parametric</td>
<td>.prt, .asm</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Pro/ENGINEER®</td>
<td>.prt, .asm</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Solid Edge®</td>
<td>.par, .asm</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>SolidWorks®</td>
<td>.sldprt, .sldasm</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>SpaceClaim®</td>
<td>.scdoc</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>DXF (2D only)</td>
<td>.dxf</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Parasolid®</td>
<td>.x_t, .xmt_txt, .x_b, .xmt_bin</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>ACIS®</td>
<td>.sat, .sab, .asat, .asab</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Step®</td>
<td>.step, .stp</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>IGES®</td>
<td>.iges, .igs</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>CATIA® V5</td>
<td>.CATPart, .CATProduct</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>VRML, v1</td>
<td>.wrl</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>STL</td>
<td>.stl</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

1Requires LiveLink™ for AutoCAD®
2Requires one of the LiveLink™ products for AutoCAD®, Creo™ Parametric, Inventor®, Pro/ENGINEER®, Solid Edge®, SolidWorks®, or SpaceClaim®, or the CAD Import Module
3Requires LiveLink™ for Solid Edge®
4Requires LiveLink™ for SpaceClaim®
5Requires the CAD Import Module (or one of the LiveLink™ products for AutoCAD®, Creo™ Parametric, Inventor®, Pro/ENGINEER®, Solid Edge®, SolidWorks®, or SpaceClaim®) and the File Import for CATIA® V5
6From/To file via linked CAD package
7Limited functionality for a single geometric domain only

ECAD

The ECAD Import Module allows for import of 2D layout files with automatic conversion to 3D CAD models. The Touchstone file type is used for exporting S-parameters, impedance, and admittance values from simultaneous port and
frequency sweeps. The SPICE Circuit Netlist file type is converted at import to a series of lumped circuit element nodes under an Electrical Circuit node.

<table>
<thead>
<tr>
<th>FILE TYPE</th>
<th>EXTENSION</th>
<th>READ</th>
<th>WRITE</th>
</tr>
</thead>
<tbody>
<tr>
<td>NETEX-G(^1)</td>
<td>.asc</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>ODB++(X)(^1)</td>
<td>.xml</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>GDS(^1)</td>
<td>.gds</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Touchstone</td>
<td>.s2p, .s3p, .s4p, ...</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>SPICE Circuit Netlist(^2)</td>
<td>.cir</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>

\(^1\) Requires the ECAD Import Module  
\(^2\) Requires one of the AC/DC, RF, MEMS, or Plasma Modules

MATERIAL DATABASES

The Chemical Reaction Engineering Module can read CHEMKIN files to simulate complex chemical reactions in the gas phase. The Plasma Module can read LXCAT files for sets of electron impact collision cross-sections.

<table>
<thead>
<tr>
<th>FILE TYPE</th>
<th>EXTENSION</th>
<th>READ</th>
<th>WRITE</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHEMKIN(^1)</td>
<td>.dat, .txt, .inp(^3)</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>CAPE-OPEN(^1) (direct connection)</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
</tr>
<tr>
<td>LXCAT file(^2)</td>
<td>.lxcat, .txt</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>

\(^1\) Requires Chemical Reaction Engineering Module  
\(^2\) Requires Plasma Module  
\(^3\) Any extension is allowed, these are the most common extensions
**Mesh**

The NASTRAN Bulk Data file types are used to import a volumetric mesh. The VRML and STL file types are used to import a triangular surface mesh, and cannot be used for creating a volumetric mesh. If imported as a Geometry, then VRML and STL files can be used as a basis for creating a volumetric mesh for a single geometric domain.

<table>
<thead>
<tr>
<th>FILE TYPE</th>
<th>EXTENSION</th>
<th>READ</th>
<th>WRITE</th>
</tr>
</thead>
<tbody>
<tr>
<td>NASTRAN Bulk Data</td>
<td>.nas, .bdf, .nastran, .dat</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>VRML, v1</td>
<td>.vrml, .wrl</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>STL</td>
<td>.stl</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

**Images and Movies**

Results visualization can be exported to a number of common image file types, see the table below. Images can also be read and used as interpolation functions for physics modeling. Animations can be exported to one of the Animated GIF, Adobe Flash, and AVI file types.

<table>
<thead>
<tr>
<th>FILE TYPE</th>
<th>EXTENSION</th>
<th>READ</th>
<th>WRITE</th>
</tr>
</thead>
<tbody>
<tr>
<td>JPEG</td>
<td>.jpg, .jpeg</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>PNG</td>
<td>.png</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>BMP</td>
<td>.bmp</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>TIFF</td>
<td>.tif, .tiff</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>GIF</td>
<td>.gif</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>EPS (1D graphs only)</td>
<td>.eps</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Animated GIF</td>
<td>.gif</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Adobe® Flash</td>
<td>.swf</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>AVI(^1)</td>
<td>.avi</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>

\(^1\) Available for Windows only
Programming Languages and Spreadsheet

Model Java Files are editable script files, with the extension .java, that contain sequences of COMSOL Multiphysics commands as Java code. Edit the files in a text editor to add additional commands. You can compile these Java files into Java Class files, with the extension .class, and run them as separate applications.

Model M-files are editable script files, similar to the Model Java-files, for use with MATLAB. Model M-files, which have the extension .m, contain a sequence of COMSOL Multiphysics commands as a MATLAB M-file. Run the Model M-files in MATLAB like any other M-file scripts. Also edit the files in a text editor to include additional COMSOL Multiphysics commands or general MATLAB commands. Running files in the Model M-file format requires the COMSOL LiveLink™ for MATLAB®.

<table>
<thead>
<tr>
<th>FILE TYPE</th>
<th>EXTENSION</th>
<th>READ</th>
<th>WRITE</th>
</tr>
</thead>
<tbody>
<tr>
<td>MATLAB®: Model M-File</td>
<td>.m</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>MATLAB®: Function¹</td>
<td>.m</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Java: Model Java File</td>
<td>.java</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Java: Model Class File</td>
<td>.class</td>
<td></td>
<td></td>
</tr>
<tr>
<td>C: Function</td>
<td>.dll³, .so⁴, .dylib⁵</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Excel®²</td>
<td>.xlsx</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

¹Requires LiveLink™ for MATLAB®
²Requires LiveLink™ for Excel®, available for Windows only
³Available for Windows only
⁴Available for Linux only
⁵Available for Mac OS X only
**NUMERICAL AND INTERPOLATION DATA FORMATS**

The Grid, Sectionwise, and Spreadsheet file types can be read for defining Interpolation functions. The Sectionwise and Spreadsheet file types can furthermore be read and used for defining Interpolation curves and written for exporting Results. In addition, Tables can be copy-pasted on spreadsheet format. Parameters and Variables can be imported and exported to the Plain text, Comma-separated values, or Data file types.

The Continuous and Discrete color table text file types are used for user-defined color tables for Results visualization.

Digital Elevation Model (DEM) files can be read and used as a Parametric Surface for defining a Geometry.

<table>
<thead>
<tr>
<th>FILE TYPE</th>
<th>EXTENSION</th>
<th>READ</th>
<th>WRITE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy and paste spreadsheet format</td>
<td>n/a</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Excel® spreadsheet¹</td>
<td>.xlsx</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Table</td>
<td>.txt, .csv, .dat</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Grid</td>
<td>.txt</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Sectionwise</td>
<td>.txt, .csv, .dat</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Spreadsheet</td>
<td>.txt, .csv, .dat</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Parameters</td>
<td>.txt, .csv, .dat</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Variables</td>
<td>.txt, .csv, .dat</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Continuous and Discrete color table</td>
<td>.txt</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>DEM</td>
<td>.dem</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>

¹Requires LiveLink™ for Excel®, available for Windows only
The following table shows the options to start COMSOL and the different linked partner software using the LiveLink add-ons.

<table>
<thead>
<tr>
<th>COMSOL® Product</th>
<th>Can Start COMSOL from Partner Software</th>
<th>Can Start Partner Software from COMSOL</th>
<th>Can Connect Running Sessions</th>
</tr>
</thead>
<tbody>
<tr>
<td>LiveLink™ for Excel®</td>
<td>Yes¹</td>
<td>Yes²</td>
<td>No</td>
</tr>
<tr>
<td>LiveLink™ for MATLAB®</td>
<td>Yes³</td>
<td>Yes⁴</td>
<td>Yes⁵</td>
</tr>
<tr>
<td>LiveLink™ for AutoCad®</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>LiveLink™ for Creo™ Parametric</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>LiveLink™ for Inventor®</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>- Bidirectional Mode</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- One Window Mode</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>LiveLink™ for Pro/ENGINEER®</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>LiveLink™ for Solid Edge®</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>LiveLink™ for SolidWorks®</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>- Bidirectional Mode</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>- One Window Mode</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>LiveLink™ for SpaceClaim®</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>

¹ When you open a COMSOL model from Excel, a COMSOL model window starts and a link is established automatically. The COMSOL model window is an output window that displays geometry, mesh, and results.

² A COMSOL model that includes a table reference to an Excel spreadsheet automatically starts an Excel process in the background when the model is run in COMSOL Desktop.

³ You can start a COMSOL Server from a MATLAB session using the "system" command and then connect to it using "mphstart" in the MATLAB command prompt.
4 The “COMSOL 4.3b with MATLAB” desktop shortcut starts a COMSOL Server and MATLAB, then connects them automatically. When you run a COMSOL model in the COMSOL Desktop that includes a MATLAB function (Global Definitions>Functions), a MATLAB engine and connection is started automatically.

5 You can connect a MATLAB session to a running COMSOL Server using the COMSOL command “mphstart” in the MATLAB command prompt.

<table>
<thead>
<tr>
<th>COMSOL® Product</th>
<th>Can Start COMSOL from Partner Software</th>
<th>Can Start Partner Software from COMSOL</th>
<th>Can Connect Running Sessions</th>
</tr>
</thead>
</table>

**Table:**

- **COMSOL® Product:**
  - Can Start COMSOL from Partner Software
  - Can Start Partner Software from COMSOL
  - Can Connect Running Sessions

4 The “COMSOL 4.3b with MATLAB” desktop shortcut starts a COMSOL Server and MATLAB, then connects them automatically. When you run a COMSOL model in the COMSOL Desktop that includes a MATLAB function (Global Definitions>Functions), a MATLAB engine and connection is started automatically.

5 You can connect a MATLAB session to a running COMSOL Server using the COMSOL command “mphstart” in the MATLAB command prompt.